Results 1 to 10 of 14

Thread: Zimbra has started deferring all mail

Hybrid View

  1. #1
    Join Date
    Oct 2005
    Posts
    22
    Rep Power
    10

    Default Zimbra has started deferring all mail

    I am testing Open Source 5.0 zimbra and it was working fine for a few weeks but
    when I started working on backup (using a perl script I found in the wiki) all mail is
    being deferred. I have restarted zimbra a number of times and have turned off AV
    I have plenty of space in my tmpfs device (700M plus 0 used). I only have a single user on and have a split domain with zimbra the slave (is-smtp-1 is the smtp server that has aliases for both post office systems, one running zimbra the other (production) running courier.

    the following is the log for a single message)

    thanks


    Feb 6 11:17:13 is-mail-2 postfix/smtpd[8245]: 2050A3184E9: client=is-smtp-1.mdtsoft.com[209.101.192.25]
    Feb 6 11:17:13 is-mail-2 postfix/cleanup[8265]: 2050A3184E9: message-id=<937d27e10802060813o6934561jc0a1d3e428d9ad81@ma il.gmail.com>
    Feb 6 11:17:13 is-mail-2 postfix/qmgr[7629]: 2050A3184E9: from=<pgsql-hackers-owner+m113708=pwd=mdtsoft.com@postgresql.org>, size=4157, nrcp
    t=1 (queue active)
    Feb 6 11:17:13 is-mail-2 postfix/qmgr[7629]: 2050A3184E9: to=<pwd@mdtsoft.com>, orig_to=<pwd@is-mail-2.mdtsoft.com>, relay=none, delay=0.13,
    delays=0.12/0.01/0/0, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while sending DA
    TA command)
    Feb 6 11:17:13 is-mail-2 postfix/smtpd[8245]: disconnect from is-smtp-1.mdtsoft.com[209.101.192.25]
    Feb 6 11:17:53 is-mail-2 postfix/smtpd[8245]: connect from is-smtp-1.mdtsoft.com[209.101.192.25]
    Feb 6 11:17:53 is-mail-2 postfix/smtpd[8245]: setting up TLS connection from is-smtp-1.mdtsoft.com[209.101.192.25]
    Feb 6 11:17:53 is-mail-2 postfix/smtpd[8245]: TLS connection established from is-smtp-1.mdtsoft.com[209.101.192.25]: TLSv1 with cipher DHE-R
    SA-AES256-SHA (256/256 bits)
    Feb 6 11:17:53 is-mail-2 postfix/smtpd[8245]: 44E0E3184EB: client=is-smtp-1.mdtsoft.com[209.101.192.25]
    Feb 6 11:17:53 is-mail-2 postfix/cleanup[8265]: 44E0E3184EB: message-id=<200802061627.m16GR63D024793@is-smtp-1.mdtsoft.com>
    Feb 6 11:17:53 is-mail-2 postfix/qmgr[7629]: 44E0E3184EB: from=<nobody@is-mail-2.mdtsoft.com>, size=1302, nrcpt=1 (queue active)
    Feb 6 11:17:53 is-mail-2 postfix/qmgr[7629]: warning: connect to transport retry: No such file or directory
    Feb 6 11:17:53 is-mail-2 postfix/qmgr[7629]: 44E0E3184EB: to=<pwd@mdtsoft.com>, orig_to=<pwd@is-mail-2.mdtsoft.com>, relay=none, delay=0.08,
    delays=0.07/0.01/0/0, dsn=4.3.0, status=deferred (mail transport unavailable)
    Feb 6 11:17:53 is-mail-2 postfix/smtpd[8245]: disconnect from is-smtp-1.mdtsoft.com[209.101.192.25]
    Feb 6 11:18:04 is-mail-2 zmmailboxdmgr[9253]: status requested
    Feb 6 11:18:04 is-mail-2 zmmailboxdmgr[9253]: status OK

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Let's see the output of:
    host `hostname` <--backticks not single quotes
    dig any mdtsoft.com
    your /etc/hosts file
    zmprov ga pwd@mdtsoft.com | grep Transport

  3. #3
    Join Date
    Oct 2005
    Posts
    22
    Rep Power
    10

    Default troubleshooting info

    /etc/hosts

    [root@is-mail-2 log]# more /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6
    209.101.192.49 is-mail-2.mdtsoft.com is-mail-2
    [root@is-mail-2 log]#


    [root@is-mail-2 log]# host `hostname`
    is-mail-2.mdtsoft.com has address 209.101.192.49
    [root@is-mail-2 log]#

    [root@is-mail-2 log]# dig any mdtsoft.com

    ; <<>> DiG 9.4.2 <<>> any mdtsoft.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12837
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 7, AUTHORITY: 0, ADDITIONAL: 6

    ;; QUESTION SECTION:
    ;mdtsoft.com. IN ANY

    ;; ANSWER SECTION:
    mdtsoft.com. 86400 IN SOA is-net-2.mdtsoft.com. is.mdtsoft.com. 863 1200 240 1209600 3600
    mdtsoft.com. 86400 IN NS is-net-1.mdtsoft.com.
    mdtsoft.com. 86400 IN NS is-net-2.mdtsoft.com.
    mdtsoft.com. 86400 IN NS guam.mdtsoft.com.
    mdtsoft.com. 86400 IN NS spock.mdtsoft.com.
    mdtsoft.com. 86400 IN MX 10 is-smtp-2.mdtsoft.com.
    mdtsoft.com. 86400 IN MX 10 is-smtp-1.mdtsoft.com.

    ;; ADDITIONAL SECTION:
    guam.mdtsoft.com. 86400 IN A 209.101.192.2
    is-net-1.mdtsoft.com. 86400 IN A 209.101.192.169
    is-net-2.mdtsoft.com. 86400 IN A 209.101.192.168
    spock.mdtsoft.com. 86400 IN A 209.101.192.158
    is-smtp-1.mdtsoft.com. 86400 IN A 209.101.192.25
    is-smtp-2.mdtsoft.com. 86400 IN A 209.101.192.119

    ;; Query time: 2 msec
    ;; SERVER: 209.101.192.169#53(209.101.192.169)
    ;; WHEN: Thu Feb 7 06:39:44 2008
    ;; MSG SIZE rcvd: 301



    NOTE I am (and it was working like a charm) running a "split domain" is-smtp-* are
    ONLY smtp servers and run canit anti spam. They are set up to forward to the two
    (production, courier and testing, zimbra is-mail-2) server by user name (right now
    only 1 user on is-mail-2 and mail is also sent to the courier server).

    I have zimbra set to always relay to is-smtp-1

    Thanks

    P.S. all of these commands where run ON is-mail-2 by the user root. is-mail-2 is a
    Fedora 7 (Moonshine) with yum -y update done just before the install of zimbra (version 5.0.0 GR Open Source)

    [root@is-mail-2 log]# rpm -qi zimbra-core
    Name : zimbra-core Relocations: (not relocatable)
    Version : 5.0.0_GA_1869.F7 Vendor: Zimbra, Inc.
    Release : 20071218205447 Build Date: Wed 19 Dec 2007 12:01:54 AM EST
    Install Date: Wed 09 Jan 2008 08:34:50 AM EST Build Host: build20.re.zimbra.com
    Group : Applications/Messaging Source RPM: zimbra-core-5.0.0_GA_1869.F7-20071218205447.src.rpm
    Size : 270725388 License: Various
    Signature : (none)
    Packager : Zimbra, Inc.
    URL : http://www.zimbra.com
    Summary : Zimbra Core
    Description :
    Best email money can buy


    Hope this helps

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Can you ping/telnet between these ports?
    Just wanted to double check my understanding of the setup: Are is-smtp-1 & is-smtp-2 tied into a multi server setup with is-mail-2 -if those 3 are zimbra boxes what's the mail transport?
    You haven't said it but looking at your dns records would suggest that smtp1/2 are sendmail boxes?
    From above:
    mail1 courier
    mail2 zimbra
    While you have an MX record, try out Pingability.com: Web Site Monitoring and Alert Service it looks to me that you're missing an external A record on your main domain. (www. mdtsoft.com is just a CNAME record pointing to fiji.mdtsoft.com)
    Said 5.0 what's the full version string? (zmcontrol -v)
    Last edited by mmorse; 02-11-2008 at 09:16 AM.

  5. #5
    Join Date
    Oct 2005
    Posts
    22
    Rep Power
    10

    Default more troubleshooting

    I am running zimbra as a secondary at least if I understand primary vs. secondary I am

    I won't try to draw but

    1) I have two servers that are the external MX records that do two things
    a) antispam
    b) route mail to the correct mailbox server systems (some *@mdtsoft.com people
    get there mail on external servers.

    2) I have two internal post office server 1 is a courier server that we have been
    running for years (this is the target to be replaced by zimbra0
    second a test server running zimbra, I have one user (myself) who gets his
    mail on both server (for now). I have a system to provision the smtp servers (and the
    courier systems will be upgraded to provision zimbra) that sets up the necessary
    stuff to get the mail where it belongs.

    3) I have set up zimbra (and to always forward all outgoing mail to is-smtp-1 (this also appears not to work now but it did)



    Anyway here is the output of zmprov.....

    [root@is-mail-2 pwd]# su - zimbra
    [zimbra@is-mail-2 ~]$ zmprov ga pwd@mdtsoft.com | grep Transport
    zimbraMailTransport: lmtp:is-mail-2.mdtsoft.com:7025
    [zimbra@is-mail-2 ~]$

  6. #6
    Join Date
    Oct 2005
    Posts
    22
    Rep Power
    10

    Default zimbra is self contained

    This is a single server setup. The mail is getting to is-mail-1 (is-smtp-1 is running sendmail and anti spam only) (from the log) it appears to me that the message is being
    received without problems by the zimbra server but for some reason it can't get it to the
    correct mailbox now. (the sendmail log on is-smtp-1 bears this out)

    also the messages are building up in the deferred que.

Similar Threads

  1. Replies: 9
    Last Post: 03-01-2008, 08:21 PM
  2. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 11:13 AM
  3. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  4. fatal: Queue report unavailable - mail system is down
    By zzzzsg in forum Administrators
    Replies: 16
    Last Post: 08-24-2006, 03:31 AM
  5. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 01:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •