Results 1 to 3 of 3

Thread: 4.0.5 on RHEL4 Restore Error

  1. #1
    Join Date
    Jan 2008
    Location
    France
    Posts
    15
    Rep Power
    7

    Default 4.0.5 on RHEL4 Restore Error

    Hi Forum,

    I'm trying to restore accounts from backups on a freshly installed ZCS 4.0.5 on a RHEL4.

    When I run the command 'zmrestore -s mail.maydomain.tld -a all -t /mnt/zimbra/backup/', I get the following error (and no logs) :
    Error occurred: unknown document: RestoreRequest

    I don't understand what matters...
    Any idea ?

    Regards,
    Patrice.

  2. #2
    Join Date
    Jan 2008
    Location
    France
    Posts
    15
    Rep Power
    7

    Default [SOLVED] 4.0.5 on RHEL4 Restore Error

    Thx to Klug from the French community I solved it...

    I was trying to do a simple restore while I had to do a "Disaster Recovery" :
    Network Edition Disaster Recovery - Zimbra :: Wiki

    Doing a disaster recovery, you should particularly be careful with keeping domain names, admin/spam-engine/LDAP usernames and password.

    If you do a disaster recovery on a different host, you should have resolution about MX entries for the main domain and at least one of the IP from the MX entries must be configured on the target host.

    During restoration if, LDAP don't start after "zmrestoreldap -lb <label>", just start it by hand with :
    Code:
    sudo /opt/zimbra/openldap/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldap://your-server.name.tld:389 -f /opt/zimbra/conf/slapd.conf
    If you encounter the following error when trying to restore mailboxes :
    Error occurred: system failure: Backup set may be incomplete

    Don't worry, your backups may not be corrupted, you should only change rights on their "session.dat" files as follows :
    Code:
    find /opt/zimbra/backup -name 'session.dat' -exec chmod 444 {} \;
    Hope this could help somebody else.

    Pat.

  3. #3
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Je n'avais pas vu ton post ici...
    J'y aurai répondu ici aussi si je l'avais vu 8)

    Ici en français : Forum de la communauté Zimbra francophone / Erreur à la restauration de comptes
    Last edited by Klug; 02-12-2008 at 11:50 AM.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 04:58 AM
  3. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 11:30 PM
  4. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM
  5. Building native libraries on MacOS X
    By ajmas in forum Developers
    Replies: 3
    Last Post: 10-15-2005, 12:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •