Results 1 to 5 of 5

Thread: imapproxy asking for password

Hybrid View

  1. #1
    Join Date
    Jul 2007
    Location
    Brazil
    Posts
    55
    Rep Power
    8

    Question imapproxy asking for password

    Hi,

    I upgrade Zimbra from 4.5.10 to 5.0.2 and when I try to start the
    imapproxy asking for password as show below.

    [zimbra@mailhost ~]$ zmcontrol start
    Host mailhost.mydomain.br
    Starting ldap...Done.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting imapproxy...Password:

    How do I do to fix this?

    Best regards,
    Bibo

  2. #2
    Join Date
    Feb 2007
    Location
    Broomfield, CO
    Posts
    26
    Rep Power
    8

    Default

    just a thought... Is the key file for imap proxy (nginx.key) encrypted, to where it needs a passphrase to start?

    OpenSSL Command-Line HOWTO

    Just an idea

    Tommy

  3. #3
    Join Date
    Jul 2007
    Location
    Brazil
    Posts
    55
    Rep Power
    8

    Default

    Hi,

    I need to know the passphrase to remove the password, isnīt it?
    What is the passphrase?

    Best regards,
    Bibo

    Quote Originally Posted by TommyTheKid View Post
    just a thought... Is the key file for imap proxy (nginx.key) encrypted, to where it needs a passphrase to start?

    OpenSSL Command-Line HOWTO

    Just an idea

    Tommy

  4. #4
    Join Date
    Feb 2007
    Location
    Broomfield, CO
    Posts
    26
    Rep Power
    8

    Default

    Haha. that is always the question. I suggest copying the nginx.key aside and copying the slapd.key over the top of the current nginx.key as a test...

    Code:
    su - zimbra
    cd conf
    
    cp nginx.key old-nginx.key
    cp nginx.crt old-nginx.crt
    
    cp slapd.key nginx.key
    cp slapd.crt nginx.crt
    
    zmproxyctl restart
    Then, your imap proxy should be using the same certificate and key as your ldap server, which doesn't appear to ask for a password. I will warn you though, I am just piddling around with a local vmware instance on my laptop, not a production server

    Tommy

  5. #5
    Join Date
    Mar 2006
    Location
    Greenwood, IN
    Posts
    90
    Rep Power
    9

    Default

    Make sure sudoers is correct.

    /etc/sudoers:
    %zimbra ALL=NOPASSWD:/opt/zimbra/nginx/sbin/nginx

Similar Threads

  1. remove/disable imapproxy
    By demanl in forum Administrators
    Replies: 8
    Last Post: 08-05-2008, 03:57 PM
  2. Replies: 9
    Last Post: 03-01-2008, 07:21 PM
  3. Replies: 5
    Last Post: 10-19-2006, 02:25 AM
  4. IMAPPROXY and TOMCAT not running Problem
    By demanl in forum Administrators
    Replies: 1
    Last Post: 10-06-2006, 07:46 PM
  5. unwanted imapproxy installed
    By Spencer in forum Installation
    Replies: 4
    Last Post: 08-10-2006, 09:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •