Results 1 to 10 of 14

Thread: FOSS upgrade fails

Threaded View

  1. #1
    Join Date
    Feb 2008
    Location
    Champaign, IL
    Posts
    9
    Rep Power
    7

    Default FOSS upgrade fails

    --Edit: The topic should be Open Source Version Upgrade, OS makes it sound like the operating system. There was no operating system upgrade. Sorry for the confusion.

    I've done a little searching and really not found a good answer as to how to remedy my issue, so here is my first post.
    Please bear in mind that I've been a router jockey for the last 8 years and don't really have any current mail admin experience.
    That said, I have a machine (Debian 4.0 2.6.18-5-486) that had been running a pilot of ZCS that I moved to a new subnet and also tried to upgrade (yeah, I know, I tried to make too many changes at once). Anyway, I'm now seeing this error:
    <snip>
    Code:
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    Operations logged to /tmp/zmsetup.02122008-071935.log
    Starting ldap...done.
    Setting defaults...done.
    Upgrading from  to 5.0.2_GA_1975
    Stopping zimbra services
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql
    Starting logger mysql
    Tue Feb 12 07:21:01 2008: SELECT value FROM config WHERE name = 'db.version'
    ERROR 1045 (28000): Access denied for user 'zimbra'@'localhost' (using password: YES)
    I can't upgrade version 
    UPGRADE FAILED - exiting
    </snip>

    The versions are as such:
    from version zcs-5.0.0_RC2_1745.DEBIAN4.0.20071120152822
    to version zcs-5.0.2_GA_1975.DEBIAN4.0.20080130234700

    All upgrade aspects appear to be fine until this one fails.
    I can start zimbra (after adjusting the postfix version using "zmlocalconfig -f -e postfix_version='2.4.3.4z'") but can't seem to do anything frm the web interface (authentication fails) and the admin page shows nothing at al (i.e. no login area).
    I'm not afraid to get my hands dirty working on this if someone can point me in the right direction.
    Any help apreciated, Thanks in advance.

    nb
    Last edited by buraglio; 02-12-2008 at 12:45 PM. Reason: Clarification.

Similar Threads

  1. Upgrade from ZCS 5.0 GA FOSS to ZCA 5.0 NE
    By fcolpron in forum Installation
    Replies: 7
    Last Post: 01-22-2008, 12:44 PM
  2. Replies: 5
    Last Post: 01-06-2008, 11:33 PM
  3. Replies: 5
    Last Post: 12-04-2007, 05:40 PM
  4. ubuntu upgrade to 4.5.9 fails
    By jeepville in forum Installation
    Replies: 9
    Last Post: 11-01-2007, 11:44 AM
  5. Replies: 5
    Last Post: 03-01-2007, 03:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •