Results 1 to 1 of 1

Thread: IM Hanging during connection (Psi 0.11 vs NPE 5.0.2)

  1. #1
    Join Date
    Feb 2007
    Location
    Broomfield, CO
    Posts
    26
    Rep Power
    8

    Arrow IM Hanging during connection (Psi 0.11 vs NPE 5.0.2)

    I am in the middle of a migration, and have an issue. Lets get some background...

    The IM server that we currently uses is also XMPP, but its completely standalone and we want one integrated into the collab solution. It currently uses username@im.domain.com.

    I had noticed that I could sign in with a JID of ANY of my email aliases on Zimbra (first.last@domain.com is an alias to username@zimbra.domain.com both work for login). I cannot seem to use aliases when adding users (seems like a bug?) but I can use it for login, so I got a wise idea to add another domain "im.domain.com" and add an alias to every user... that has been completed, but I cannot login with that.. it hangs... here is the XMPP output


    NOTE that this connection was using port 5223 (ssl)


    Code:
    <?xml version="1.0"?>
    
    <stream:stream xmlns:stream="http://etherx.jabber.org/streams" version="1.0" xmlns="jabber:client" to="im.domain.com" xml:lang="en" xmlns:xml="
    http://www.w3.org/XML/1998/namespace" >
    
    <?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" from="im.domain.com"
     id="85760813" xml:lang="en" version="1.0">
    
    
    <stream:features>
    <mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
    <mechanism>PLAIN</mechanism>
    </mechanisms>
    <compression xmlns="http://jabber.org/features/compress">
    <method>zlib</method>
    </compression>
    <auth xmlns="http://jabber.org/features/iq-auth"/>
    <register xmlns="http://jabber.org/features/iq-register"/>
    </stream:features>
    
    
    <auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN" >(censored)</auth>
    
    
    <success xmlns="urn:ietf:params:xml:ns:xmpp-sasl"/>
    
    
    <?xml version="1.0"?>
    
    <stream:stream xmlns:stream="http://etherx.jabber.org/streams" version="1.0" xmlns="jabber:client" to="im.domain.com" xml:lang="en" xmlns:xml="
    http://www.w3.org/XML/1998/namespace" >
    
    <?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" from="im.domain.com"
     id="85760813" xml:lang="en" version="1.0">
    
    
    <stream:features>
    <compression xmlns="http://jabber.org/features/compress">
    <method>zlib</method>
    </compression>
    <bind xmlns="urn:ietf:params:xml:ns:xmpp-bind"/>
    <session xmlns="urn:ietf:params:xml:ns:xmpp-session"/>
    </stream:features>
    
    
    <iq type="set" id="bind_1" >
    <bind xmlns="urn:ietf:params:xml:ns:xmpp-bind">
    <resource>SuperFudge</resource>
    </bind>
    </iq>

    it just hangs there... It looks to me like its successfully logged in, but hangs when I try to tell it my resource

    Ideas?


    Just for documentation purposes, here is a successful connection to the *SAME* account, using a different alias (first.last@domain.com instead of username@im.domain.com)

    Code:
    <?xml version="1.0"?>
    
    
    <stream:stream xmlns:stream="http://etherx.jabber.org/streams" version="1.0" xmlns="jabber:client" to="domain.com" xml:lang="en" xmlns:xml="http://www.w3.org/XML/1998/namespace" >
    
    
    <?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" from="domain.com" id="81165074" xml:lang="en" version="1.0">
    
    
    <stream:features>
    <mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
    <mechanism>PLAIN</mechanism>
    </mechanisms>
    <compression xmlns="http://jabber.org/features/compress">
    <method>zlib</method>
    </compression>
    <auth xmlns="http://jabber.org/features/iq-auth"/>
    <register xmlns="http://jabber.org/features/iq-register"/>
    </stream:features>
    
    
    <auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN" >(censored)</auth>
    
    
    <success xmlns="urn:ietf:params:xml:ns:xmpp-sasl"/>
    
    
    <?xml version="1.0"?>
    
    
    <stream:stream xmlns:stream="http://etherx.jabber.org/streams" version="1.0" xmlns="jabber:client" to="domain.com" xml:lang="en" xmlns:xml="http://www.w3.org/XML/1998/namespace" >
    
    
    <?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" from="domain.com" id="81165074" xml:lang="en" version="1.0">
    
    
    <stream:features>
    <compression xmlns="http://jabber.org/features/compress">
    <method>zlib</method>
    </compression>
    <bind xmlns="urn:ietf:params:xml:ns:xmpp-bind"/>
    <session xmlns="urn:ietf:params:xml:ns:xmpp-session"/>
    </stream:features>
    
    
    <iq type="set" id="bind_1" >
    <bind xmlns="urn:ietf:params:xml:ns:xmpp-bind">
    <resource>Psi-Laptop</resource>
    </bind>
    </iq>
    
    
    <iq xmlns="jabber:client" type="result" id="bind_1" to="domain.com/81165074" >
    <bind xmlns="urn:ietf:params:xml:ns:xmpp-bind">
    <jid>tommy@zimbra-usi.domain.com/Psi-Laptop</jid>
    </bind>
    </iq>
    
    
    <iq type="set" id="aca3a" >
    <session xmlns="urn:ietf:params:xml:ns:xmpp-session"/>
    </iq>
    
    
    <iq type="result" id="aca3a" to="tommy@zimbra-usi.domain.com/Psi-Laptop" >
    <session xmlns="urn:ietf:params:xml:ns:xmpp-session"/>
    </iq>
    
    
    <iq type="get" id="aca4a" >
    <query xmlns="jabber:iq:roster"/>
    </iq>
    
    
    <iq type="result" id="aca4a" to="tommy@zimbra-usi.domain.com/Psi-Laptop" >
    <query xmlns="jabber:iq:roster">
    <item subscription="none" ask="subscribe" name="Test Two" jid="test2@zimbra-usi.domain.com" >
    <group>Buddies</group>
    </item>
    <item subscription="none" ask="subscribe" name="Test One" jid="test1@zimbra-usi.domain.com" >
    <group>Buddies</group>
    </item>
    *** SNIP'd a BUNCH OF THESE ***
    /query>
    </iq>
    
    
    <presence>
    <priority>10</priority>
    <c xmlns="http://jabber.org/protocol/caps" node="http://psi-im.org/caps" ver="0.11-dev-rev8" ext="cs ep-notify html" />
    </presence>
    
    
    <iq type="get" id="aca6a" >
    <query xmlns="jabber:iq:private">
    <storage xmlns="storage:bookmarks"/>
    </query>
    </iq>
    
    
    <iq type="get" to="tommy@zimbra-usi.domain.com" id="aca7a" >
    <vCard xmlns="vcard-temp" version="2.0" prodid="-//HandGen//NONSGML vGen v1.0//EN" />
    </iq>
    
    
    <iq type="get" to="zimbra-usi.domain.com" id="aca8a" >
    <query xmlns="http://jabber.org/protocol/disco#info"/>
    </iq>
    
    *** SNIPPED A BUNCH OF PRESENCE INFO ***
    
    <iq from="zimbra-usi.domain.com" type="result" id="aca8a" to="tommy@zimbra-usi.domain.com/Psi-Laptop" >
    <query xmlns="http://jabber.org/protocol/disco#info">
    <identity category="server" type="im" name="Wildfire Server" />
    <feature var="http://jabber.org/protocol/disco#info" />
    <feature var="jabber:iq:register" />
    <feature var="jabber:iq:privacy" />
    <feature var="vcard-temp" />
    <feature var="jabber:iq:version" />
    <feature var="jabber:iq:last" />
    <feature var="http://jabber.org/protocol/address" />
    <feature var="jabber:iq:private" />
    <feature var="http://jabber.org/protocol/disco#items" />
    <feature var="jabber:iq:roster" />
    <feature var="http://jabber.org/protocol/commands" />
    <feature var="http://jabber.org/protocol/offline" />
    <feature var="jabber:iq:time" />
    </query>
    </iq>
    
    *** and ready for business

    Tommy
    Last edited by TommyTheKid; 02-20-2008 at 09:35 PM. Reason: added more details

Similar Threads

  1. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 05:32 PM
  2. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  3. Lots of deferred errors all of a sudden
    By CdtDelta in forum Administrators
    Replies: 0
    Last Post: 12-01-2007, 08:27 AM
  4. Replies: 3
    Last Post: 07-19-2007, 03:00 AM
  5. SMTP SSL Problem
    By nexus in forum Installation
    Replies: 8
    Last Post: 03-15-2007, 08:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •