Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Can not access admin console after 5.0.2 upgrade

  1. #21
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    Quote Originally Posted by iggy View Post
    Thank you for the files. Give us a moment to analyze and we'll get right back to you.
    The supplied slapd.conf.in clearly illustrates why this error is occuring:

    Code:
    # only allow access to these attrs basically GAL/Postfix related attrs
    
    access to dn.subtree="ou=people,dc=XXXXX,dc=com"
            by * read
    
    access to dn.subtree="ou=groups,dc=XXXXX,dc=com"
            by * read
    Since you've locked down all access to those subtrees to READ only, nothing can write to it. You need to fix your ACLS to be like:

    Code:
    # only allow access to these attrs basically GAL/Postfix related attrs
    
    access to dn.subtree="ou=people,dc=XXXXXXX,dc=com"
            by dn.children="cn=admins,cn=zimbra" write
            by * read
    
    access to dn.subtree="ou=groups,dc=XXXXXXX,dc=com"
            by dn.children="cn=admins,cn=zimbra" write
            by * read
    Also, I'd advise you to move all the index statements that got added up with the other index statements, and move the added access lines to before the

    Code:
    #overlay syncprov
    line, as overlays are the last things that should be listed in a given database configuration. If you later enable replication, you may hit problems with your current configs.

    --Quanah
    Last edited by quanah; 02-28-2008 at 01:51 PM.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  2. #22
    Join Date
    Jul 2007
    Location
    Ohio
    Posts
    33
    Rep Power
    8

    Default

    That has fixed it, though I should note that the entries I had came straight from the wiki page on LDAP/Samba integration and were the same ones that worked fine on 4.5.x.

  3. #23
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    Quote Originally Posted by wolrah View Post
    That has fixed it, though I should note that the entries I had came straight from the wiki page on LDAP/Samba integration and were the same ones that worked fine on 4.5.x.
    Yes, things changed a bit between 4.5.x and 5.0.x as we are tightening up various things. I'll make sure the wiki page gets updated appropriately.

    Regards,
    Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Similar Threads

  1. Replies: 8
    Last Post: 02-21-2008, 09:13 PM
  2. [SOLVED] Cannot access admin console
    By hendrikv in forum Installation
    Replies: 5
    Last Post: 02-04-2008, 02:18 PM
  3. Admin Console Access?
    By mosx86 in forum Installation
    Replies: 3
    Last Post: 09-24-2007, 11:49 AM
  4. Can't Access to Admin Console
    By GameSky in forum Installation
    Replies: 32
    Last Post: 05-26-2007, 01:25 AM
  5. Replies: 5
    Last Post: 03-01-2007, 03:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •