Results 1 to 3 of 3

Thread: Cannot fetch external IMAP

Hybrid View

  1. #1
    Join Date
    Feb 2008
    Rep Power

    Default Cannot fetch external IMAP

    I am running 5.0.2_GA_1975 on Ubuntu 6.06.2 LTS. I updated to the latest security patches and the latest updates. This server is running in a VMWare VM with about 1.5GB of memory dedicated to the VM. I've Installed zimbra with pretty much all of the default options as far as I can tell. Everything is working great with the exception of fetching email from external IMAP accounts.

    I've added a Gmail account to my accounts list. When I click the 'Test' button I get a 'success' message. But zimbra never makes an attempt to fetch the email. In my mailbox.log file I get the message:

    2008-02-26 09:58:15,261 INFO  [btpool0-9] [;mid=3;ip=;ua=ZimbraWebClient - FF3.0 (Linux)/5.0.2_GA_1975.UBUNTU6;] datasource - Testing DataSource: { id=TestId, type=imap, isEnabled=false, name=Test,, port=993, connectionType=ssl, username=gmailtest, folderId=-1 }
    2008-02-26 09:58:16,234 INFO  [btpool0-9] [;mid=3;ip=;ua=ZimbraWebClient - FF3.0 (Linux)/5.0.2_GA_1975.UBUNTU6;] datasource - Test succeeded
    2008-02-26 09:58:17,826 INFO  [btpool0-9] [;mid=3;ip=;ua=ZimbraWebClient - FF3.0 (Linux)/5.0.2_GA_1975.UBUNTU6;] mailbox - Created folder /Gmail, id=346
    This shows me that everything seems to be kosher. A check of my cos settings and account settings gives me the same thing for both:

    zimbraDataSourceMinPollingInterval: 1m
    zimbraDataSourcePollingInterval: 1m
    zimbraFeatureMailPollingIntervalPreferenceEnabled: TRUE
    zimbraMailMinPollingInterval: 2m
    zimbraPrefMailPollingInterval: 5m
    I've tried clicking the "Get Mail" button but that doesn't work. I have tried adding other accounts but they also don't work. One thing I did do was set zimbra up on a Suse 10.3 machine, and that machine _will_ fetch external IMAP. So I think I must be missing something obvious.

    I went through bugzilla but I could not find anything that seemed to address this. I did find a few posts on the forums that seemed promising, but the fixes didn't work.

    I am probably doing something wrong since I am new to zimbra. Does anyone have any ideas? Thanks in advance.

  2. #2
    Join Date
    Oct 2005
    Thatcher, AZ
    Rep Power


    When you hit Get Mail, does anything log to mailbox.log?

  3. #3
    Join Date
    Feb 2008
    Rep Power


    No it does not log anything.

    I did check it on the working zimbra install I have on my suse machine, and that does not appear to log anything either, but the polling does work on that installation.

    I think I found a fix though. Before I had the system-wide polling settings, then I tried setting the polling settings on my individual account. That still didn't seem to fix it.

    This time I set the zimbraDataSourcePollingInterval on the specific datasource that was my external IMAP account and zimbra immediately started fetching my mail. The command I ran was:
    zmprov mds TestIMAP zimbraDataSourcePollingInterval 5m
    So maybe I was doing something wrong from the start. The weird thing is I don't remember having to do anything special on the Suse Zimbra install. That one just seemed to work with no intervention.

Similar Threads

  1. External IMAP errors
    By Vladimir in forum Administrators
    Replies: 0
    Last Post: 01-10-2008, 12:41 PM
  2. A connector to an external IMAP Server
    By gba in forum Developers
    Replies: 1
    Last Post: 07-03-2006, 02:37 AM
  3. External IP, Cant Send IMAP
    By FastEddy760 in forum Installation
    Replies: 7
    Last Post: 03-27-2006, 01:27 AM
  4. Fetch mail from external POP3 accounts
    By timothyp in forum Installation
    Replies: 1
    Last Post: 03-16-2006, 03:38 PM
  5. Error on IMAP - Tomcat crashes!
    By rodrigoccurvo in forum Administrators
    Replies: 5
    Last Post: 11-30-2005, 07:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts