Results 1 to 3 of 3

Thread: [SOLVED] qmail-ldap integration error

  1. #1
    Join Date
    Jan 2008
    Rep Power

    Thumbs up [SOLVED] qmail-ldap integration error

    Quote Originally Posted by graffiti View Post
    It has been two months from the last time I struggled with this problem. Today when I take a look at /var/log/zimbra.log, I see something like " []: netstring format error while receiving QMQP packet header". This is probably the reason why Postfix qmqpd doest accept email forwarded by my qmail-ldap's qmqpd. I have spended hours searching on Google but still no luck. I'm using qmail-ldap Release 20050401a. Please help.

    I am also getting this error and cannot find anything on it... Any help will be appreciated.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Quote Originally Posted by bonoboslr View Post
    I am also getting this error and cannot find anything on it... Any help will be appreciated.
    You should have started a new thread with your problem instead of tagging it onto one that's fifteen months old. The problem is that the poster you've queted never followed up with any information and nether have you. How about some information on operating system, Zimbra version & release, any errors in the logs (please post full error messages), did you follow the instructions in the first post and under what circumstances do you get errors?

    Post some details of your exact problems you're seeing and the steps you've taken to diagnose the problem..


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jan 2008
    Rep Power

    Default Netstring format error [resolved]

    Agreed and point taken. However, I have managed to track down what causes this and how it can be perceived to be an error.

    OS - RHEL5
    ZimVer - 5.02
    Qmail-LDAP - 20060201

    "netstring format error while receiving QMQP packet header" is a result of incorrect qmqp headers passed to postfix qmqpd service on port 628.

    I managed to get this problem by telnet'ing to port 628 on the Zimbra postfix server. I did this because of some networking problems I was having.

    It is not really a problem, just a case of not realising that I myself caused the error. The main cause of my problem however was that my two machines - the qmail-ldap and the zimbra server are both on 2 separate vlans and I never added both networks to the authorized qmqpd clients in


Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 03:58 AM
  3. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  4. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts