Results 1 to 3 of 3

Thread: Test backup restoration problem

  1. #1
    Join Date
    Aug 2006
    Victoria, BC, Canada
    Rep Power

    Question Test backup restoration problem


    I am trying to restore a backup we have of our Zimbra installation to a test server just so that I can see that I can actually restore a backup. Before I start explaining my problems, here are the configurations involved:

    Current mail server is running Release 4.5.10_GA_1575.RHEL4_20071117152457 CentOS4 FOSS edition and is running on CentOS release 4.5 (Final).

    The test server that I am trying to restore the backup to is running Release 4.5.10_GA_1575.RHEL4_20071117152457 CentOS4 FOSS edition and is running on CentOS release 4.6 (Final).

    To backup Zimbra on our mail server, I shutdown Zimbra and then rsync the /opt/zimbra directory and all of it's contents to our backup server and then start Zimbra back up. My understanding is that in order to restore Zimbra on another server, I need restore the /opt/zimbra directory and run the install program for the exact same version of the original installed Zimbra (which I have done).

    The first time I did this I had lots of errors during the install process due to DNS. I originally gave the test server a hostname of mailbackup but I didn't add the information to the DNS cause I didn't actually want to act as a mail server. I tried different suggestions from the forums but couldn't really resolve any of the problems.

    I started over again with a fresh virtual machine and this time I gave it a hostname of localhost. This seemed to have solved most of the problems as I was able to get through the install with only a couple of warnings about MX entries not being found.

    However this time when I start Zimbra on the test server, I get the following:

    [root@localhost libexec]# su - zimbra
    [zimbra@localhost ~]$ zmcontrol stop
    Host localhost
    Stopping stats...Done
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done
    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done
    Stopping mailbox...Done
    Stopping logger...Done
    Stopping ldap...Done

    but when I check the status I get:

    Host localhost
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    mysql.server is not running
    tomcat is not running
    mta Running
    snmp Running
    spell Running
    stats Stopped

    I tried stopping zimbra, running /opt/zimbra/libexec/zmfixperms as root and then starting zimbra again but that didn't seem to change anything.

    Is the problem with restore a Zimbra backup to another server is that the hostname is not the same as what was on the original server? If so, is it possible to test a backup restoration without disrupting mail services on the actual mail server?

    Any help on resolving this would be greatly appreciated. Thank you.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Details in this blog entry: There are also some articles in the wiki and lots of threads in the forums about backup/restore.


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jan 2007
    Rep Power


    When i tried the mentioned procedure, it went flawlessly, the only thing needed changing was the zimbra UID/GID, other than that, it worked great, so you might wanna check it out.

Similar Threads

  1. Replies: 658
    Last Post: 04-04-2014, 09:01 AM
  2. Zimbra Backup Script ... Small Problem
    By frankb in forum Administrators
    Replies: 12
    Last Post: 07-14-2008, 08:40 AM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 06:07 PM
  4. Problem when restoring from incremental backup
    By Eyfi in forum Administrators
    Replies: 4
    Last Post: 06-28-2007, 08:47 AM
  5. Backup problem
    By flums in forum Administrators
    Replies: 2
    Last Post: 04-30-2007, 04:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts