Page 2 of 9 FirstFirst 1234 ... LastLast
Results 11 to 20 of 81

Thread: Enabling DSPAM

  1. #11
    Join Date
    Feb 2008
    Location
    Norway
    Posts
    59
    Rep Power
    7

    Default

    As filed as bug and reported here, it doesnt here after enabling DSPAM for some weird reason. Any thaughts of what to check to fix this?
    Release 5.0.8_GA_2462.RHEL5_20080709170039 RHEL5 FOSS edition

  2. #12
    Join Date
    Feb 2008
    Location
    Norway
    Posts
    59
    Rep Power
    7

    Default

    A little update on this problem, it actually now seems that it works just fine when using webmail, but its not working from the zimbra desktop client.....
    Release 5.0.8_GA_2462.RHEL5_20080709170039 RHEL5 FOSS edition

  3. #13
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by osiris View Post
    A little update on this problem, it actually now seems that it works just fine when using webmail, but its not working from the zimbra desktop client.....
    OK, I'd suggest filing a bug report for that or initially a post in the Desktop forum to see if it's a known problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #14
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

  5. #15
    Join Date
    Jun 2007
    Location
    Hou, Denmark
    Posts
    20
    Rep Power
    8

    Smile

    Quote Originally Posted by wfweaver View Post
    Also, has ANYONE found the answer to the whole "No Such feature 'chained'" message in the log? What is that about and how do you fix it or get rid of it?
    It seems that the "Feature chained" is deprecated in the new version of dspam.

    Have a look here: dspam-users-archive: [SOLVED] Re: [dspam-users] DSPAM 3.8.0 from

    Change "Feature chained" to "Tokenizer chained" in your

    /opt/zimbra/conf/dspam.conf

    That got rid of the error message for me, running ZCS 5.0.2 on Debian Etch

    Hans Otto Lunde
    Denmark

  6. #16
    Join Date
    Feb 2008
    Location
    Norway
    Posts
    59
    Rep Power
    7

    Default

    What about spam/ham training after enabling DSPAM?

    no matter how many times (new mails ofc..) I mark the same sort of message as ham, DSPAM always says it spam. Seems like spamassassin learned it though (BAYES_00=-2.599, DSPAM_SPAM=1.5).
    Release 5.0.8_GA_2462.RHEL5_20080709170039 RHEL5 FOSS edition

  7. #17
    Join Date
    Mar 2009
    Posts
    91
    Rep Power
    6

    Default

    I am running 5.0.13 and my amavisd.conf.in file has this line:

    %%uncomment LOCAL:amavis_dspam_enabled%%$dspam = '/opt/zimbra/dspam/bin/dspam';
    If I want to enable DSPAM, what should it look like? I am uncertain about the 2 % characters in two places on this line and the $ sign.

    kazoo

  8. #18
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    We've made it into an localconfig key (amavis_dspam_enabled) in 5.0.11+: Bug 20555 - zmfixperms is not setting dspam ownerships properly
    There's a case sensitivity bug for the word TRUE that's fixed for 5.0.14 as part of: Bug 18153 - zmtrainsa not learning from dspam when it's enabled

    Here's how it works in action (notice how the # symbol is removed after you enable):
    [zimbra@c52s32zcs600 conf]$ more amavisd.conf.in | grep dspam
    %%uncomment LOCAL:amavis_dspam_enabled%%$dspam = '/opt/zimbra/dspam/bin/dspam';

    [zimbra@c52s32zcs600 conf]$ more amavisd.conf | grep dspam
    #$dspam = '/opt/zimbra/dspam/bin/dspam';


    [zimbra@c52s32zcs600 conf]$ zmlocalconfig -e amavis_dspam_enabled=TRUE

    [zimbra@c52s32zcs600 conf]$ zmamavisdctl restart
    Stopping amavisd... done.
    Starting amavisd...done.

    [zimbra@c52s32zcs600 conf]$ more amavisd.conf.in | grep dspam
    %%uncomment LOCAL:amavis_dspam_enabled%%$dspam = '/opt/zimbra/dspam/bin/dspam';

    [zimbra@c52s32zcs600 conf]$ more amavisd.conf | grep dspam
    $dspam = '/opt/zimbra/dspam/bin/dspam';

  9. #19
    Join Date
    Apr 2009
    Posts
    1
    Rep Power
    6

    Default

    Quote Originally Posted by mmorse View Post

    ---

    Edit, 5.0.11+ we now use an zmlocalconfig attribute:

    Code:
     if [ x"$amavis_dspam_enabled" = "xtrue" ]; then
        timestampit  "Starting dspam $MODE training for $USER using folder $FOLDER"
        if [ $MODE == "ham" ]; then
            MODE="innocent"
        fi
    
        ${zimbra_home}/dspam/bin/dspam --user zimbra --class=${MODE} --source=corpus --mode=teft \
          --feature=chained,noise --stdout
    
        ${zimbra_home}/dspam/bin/dspam_clean -p0 $USER
        timestampit  "Finished dspam $MODE training for $USER using folder $FOLDER"
      fi
    
        /bin/rm -rf ${tempdir}
    
    }
    I finally learned how to enabled dspam thanks to this post.

    Can someone explain to me how/if the zmtrainsa trainAccountFolder function works with dspam? If I make this call:
    Code:
    zmtrainsa alain spam junk
    dspam waits forever on stdin... Am I missing something?

    I'm running 5.0.14FOSS, I've set amavis_dspam_enabled=TRUE and chown -R zimbra.zimbra /opt/zimbra/dspam-3.8.

    TIA
    Alain

  10. #20
    Join Date
    Dec 2007
    Location
    Stockton, CA
    Posts
    164
    Rep Power
    7

    Default

    I would like to use DSPAM with my installation of Zimbra, but I'm encountering the "No Such feature 'chained'" issue.

    I'm running Zimbra 5.0.18_GA_3011.DEBIAN4.0.FOSS.

    If I understand correctly, the steps to enabling DSPAM are relatively straightforward...

    1) zmlocalconfig -e amavis_dspam_enabled=TRUE
    2) Change owner:group on /opt/zimbra/dspam (and dspam-3.8.0) to zimbra:zimbra
    3) zmamavisdctl restart

    Now, when I do a "zmtrainsa user@domain.com spam Junk", I get:

    Code:
    20091008102102 Starting dspam spam training for user@domain.com using folder Junk
    27143: [10/08/2009 10:21:02] No such feature 'chained'
    I've checked /opt/zimbra/conf/dspam.conf to verify that "Feature chained" is changed to "Tokenizer chained", and it already is.

    Any ideas?

Similar Threads

  1. Fedora 8 install
    By ahuman in forum Installation
    Replies: 31
    Last Post: 02-15-2008, 07:37 AM
  2. Zimbra install errorr on FC 4 - Please help
    By gva_1030 in forum Installation
    Replies: 16
    Last Post: 02-14-2008, 03:52 PM
  3. Fedora - latest versions?
    By sternfan in forum Installation
    Replies: 8
    Last Post: 01-09-2008, 04:53 AM
  4. Enabling DSPAM
    By plan9 in forum Administrators
    Replies: 6
    Last Post: 07-18-2007, 10:55 AM
  5. Configuring and using DSPAM
    By JoshuaPrismon in forum Administrators
    Replies: 55
    Last Post: 03-02-2007, 08:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •