I have five servers:
2 LDAP servers
2 MTA servers
1 Mailbox server

All running version 5.0.1.

I have been running self-signed certs for over a year, and I am now install commercial certs. I am using a wildcard cert if it make any difference.

I used the web interface to generate the CSR, but it wouldn't install via the web interface. I installed it via the command-line it looks like it worked. If I view the cert in the admin interface it shows properly. However with I hit the web site or refresh the admin page it is still show the old certificate.

I then installed the comm cert on all my servers. I checked the admin interface and they are all using the new wildcard cert. But still the web interface and admin interface are using the old certificate. I have tried recreating the CA, redeploying the CA removing the /opt/zimbra/ssl/zimbra/server folder, but it is still using the old self-signed cert. I'm not even sure where it is getting the cert from

Does this have something to do with the fact that the LDAP server is a CA?

Thanks in advanced!