Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Send on Behalf

  1. #1
    Join Date
    Dec 2007
    Posts
    22
    Rep Power
    7

    Unhappy Send on Behalf

    I have recently deployed Zimbra for my business. I have multiple CS reps that all answer emails in our Sales inbox using Shared Folders.

    I really need to get rid of the "on behalf of" that appears when a rep sends a reply that was in the sales Inbox, it doesn't look very professional. Also if I setup a persona for sales, when they create a new message is there a way to get rid of it there also?

    Thanks,
    Ben

  2. #2
    Join Date
    Feb 2008
    Location
    Austria
    Posts
    32
    Rep Power
    7

    Default

    I stumbled over this "feature" too, it is really annoying. There seems to be a bug too, because the "on behalf" appears only if the mail has an indexable attachment or is bigger than a specific value.

    But the real issue for me is, zimbra modifies the From: field I set in the persona with only the e-mail address of the "on behalf" - account. e.g. Instead "Max Test" <office@domain.com>, it reads only office@domain.com.

    My quick and dirty workaround, to not let the recipient see the mail was sent "on behalf", was to use postfix header_checks to strip the Sender: header.
    But I use a Mailgateway in front of Zimbra and cannot say if would be enough to let the ZCS postfix do the same...
    /^Sender: [a-z]*\.[a-z]*@domain\.at/ IGNORE
    But I would prefer to get rid of it in Zimbra itself...

    tia,
    mjp

  3. #3
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Yes
    Very annoying indeed. There's a bug on it. Not a feature, a bug. A very annoying one too.

  4. #4
    Join Date
    Dec 2007
    Posts
    22
    Rep Power
    7

    Default

    Which part is the bug? it did it for me whenever someone replied to a message in a shared folder. I hacked a fix directly into sendMimeMessage of the mailSender. I see comments throughout the java code and js as i tracked this down that says if your replying from a share that sender address MUST be included, unless the mailbox was opened from an admin.

    Personally I don't see how anybody would want this feature, anybody that is going to use Zimbra for a CS role will hate it just like I did. If i sent a tech support email to yahoo I would expect a response from someone and I am willing to guess that the average email user that notices the "Sent on Behalf" would be instantly worried about phishing, scam, spam they are no idea how that was generated.

    Anyways just my 2 cents. I fixed it for my needs.

    Thanks,
    Ben

  5. #5
    Join Date
    Feb 2008
    Location
    Austria
    Posts
    32
    Rep Power
    7

    Default

    For me that is the bug, actually you could count it as 2.

    I stumbled over this "feature" too, it is really annoying. There seems to be a bug too, because the "on behalf" appears only if the mail has an indexable attachment or is bigger than a specific value.
    So it does send "on behalf" but only maybe, cannot rely on it.

    But the real issue for me is, zimbra modifies the From: field I set in the persona with only the e-mail address of the "on behalf" - account. e.g. Instead "Max Test" <office@domain.com>, it reads only office@domain.com.
    It is very common and reasonable for support or sales deps. to send everything from support@domain.com and to "personalise" the mail adding "Friendly Name" <support@domain.com> to the From header.
    Another problem came to my mind: Your e-mail will get a higher score in most spam filters, because of the NO_REAL_NAME check...

    Is there a bug on this too, why zimbra alters the FROM:, although there is other info in the LDAP? But it may be related...

    @jholder: you mentioned there is a bug, could you provide a bugzilla # ?

    regards,
    m
    Last edited by mjp; 03-06-2008 at 09:54 AM. Reason: update

  6. #6
    Join Date
    Sep 2007
    Posts
    38
    Rep Power
    8

    Default

    How do I get rid of the Send on Behalf - does the mjp's workaround work with ZCS postfix?

    Thank you.

  7. #7
    Join Date
    Sep 2007
    Posts
    38
    Rep Power
    8

    Default

    Anyone? Just got hit again with this "feature" on 5.0.6.

  8. #8
    Join Date
    Sep 2007
    Posts
    38
    Rep Power
    8

    Default

    Ok seems like I got it removed by adding

    /^Sender: / IGNORE

    to

    /opt/zimbra/conf/postfix_header_checks


    Restart postfix
    /opt/zimbra/postfix/sbin/postfix stop
    /opt/zimbra/postfix/sbin/postfix start


    :-)

  9. #9
    Join Date
    Jul 2006
    Location
    Stuttgart / Germany
    Posts
    223
    Rep Power
    9

    Default

    Hi all,

    some of my users are extremly irritated by the Sender: Header field as it only "sometimes" appears.
    IGNORing the Sender: header using the postfix_header_checks is a good workaround, but there should be a fix for this...

    Is there a bugreport in bugzilla for this? I could not find any...

    Regards
    Thomas

  10. #10
    Join Date
    Jan 2007
    Location
    Fort Lauderdale, FL
    Posts
    151
    Rep Power
    8

    Default i agree - bump

    I have several customers who want to alias their gmail or yahoo addresses in and not send on behalf of, this should be a flag or setting in zimbra admin someplace, is there a bug for this?

Similar Threads

  1. MTA failure send mail
    By mingswitch in forum Administrators
    Replies: 6
    Last Post: 10-14-2011, 08:21 AM
  2. Replies: 5
    Last Post: 06-18-2008, 02:50 AM
  3. Cannot send mail via connector
    By ericwk in forum Zimbra Connector for Outlook
    Replies: 10
    Last Post: 08-16-2007, 10:46 AM
  4. cannot send email to sina/yahoo
    By koolokamba in forum Administrators
    Replies: 2
    Last Post: 06-20-2006, 09:03 AM
  5. None of your e-mail accounts could send to this recipient.
    By BarrySDCA in forum Zimbra Connector for Outlook
    Replies: 2
    Last Post: 05-25-2006, 06:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •