Results 1 to 8 of 8

Thread: Closed domain, disabled mta and mailbox

  1. #1
    Join Date
    Feb 2008
    Posts
    15
    Rep Power
    7

    Default Closed domain, disabled mta and mailbox

    I was in the domains section of the administration ui and I closed the only domain on my zimbra install as well as deactivated mailbox and mta. I used zmcontrol to stop and start the service. I want to activate the domain now but I can't because I can no longer log into the admin console and zmprov lists this error:

    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)

    any ideas on how to re-enable the domain?

  2. #2
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    9

    Default

    You are probably going to have to use the Command Line Interface.

    Go to the documentation and read about the CLI. Especially "CreateDomain"

  3. #3
    Join Date
    Feb 2008
    Posts
    15
    Rep Power
    7

    Default

    That doesn't make any sense. How can I create a domain when clearly the zmprov command is not working, as I stated above.

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Single server setup? If so why did you disable mailboxd?
    If that's the case you probably need to start with:
    zmprov -l ms server.domain.com +zimbraServiceEnabled mailboxd

  5. #5
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    -l (lowercase 'ell' L) is to provision via LDAP because your mailboxd service is down.

  6. #6
    Join Date
    Feb 2008
    Posts
    15
    Rep Power
    7

    Default

    i disabled the mailboxd cause I wanted to see what would happen

    now i know

  7. #7
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    I got an email that said:
    Quote Originally Posted by otisthegbs
    thank you both for replying, i really do appreciate it, but again. as i've already said, zmprov command does not work. see the above error

    i disabled the mailboxd cause I wanted to see what would happen

    now i know
    But your post reads/quick edited to:
    Quote Originally Posted by otisthegbs View Post
    i disabled the mailboxd cause I wanted to see what would happen

    now i know
    I gather by the edit -l worked
    Are you all good? Or do you still need help on creating a domain and admin user etc?

  8. #8
    Join Date
    Feb 2008
    Posts
    15
    Rep Power
    7

    Default

    No I think I'll be ok for creating that admin user.... thanks.

    In any event, why does Zimbra's webui / mailboxd shut down if I disable the domains in the admin UI? Doesn't seem like a very intelligent thing to do. At least there should be some sort of warning saying:

    WARNING: THIS NOT AN INTELLIGENT THING TO DO!

    know what I mean? Cause I would assume that I would still get into the admin console via IP even if I disabled the domain.

Similar Threads

  1. [SOLVED] mysql.server not running
    By king0770 in forum Administrators
    Replies: 23
    Last Post: 07-25-2009, 04:07 PM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 12:34 PM
  3. domain coexistence
    By marcmac in forum Administrators
    Replies: 14
    Last Post: 06-30-2006, 02:19 PM
  4. MTA and Mailbox die periodically...
    By andreturpin in forum Administrators
    Replies: 3
    Last Post: 06-21-2006, 07:31 PM
  5. Tomcat hanging
    By Morg0 in forum Administrators
    Replies: 42
    Last Post: 04-19-2006, 09:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •