Results 1 to 5 of 5

Thread: External LDAP - Users can't log in

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Posts
    2
    Rep Power
    9

    Default External LDAP - Users can't log in

    I've configured an external Fedora Directory Server to use for authentication, and went to the Authentication Configuration Wizard to configure for external LDAP. I've entered search base, filter, and bind DN, and the Test at the end of the wizard succeeds.

    But, when I go to log in as the same user that I used for the test, login fails. Also, should the internal admin still be able to login. If not, how is the administrator determined? The internal admin cannot login in either when external authentication is enabled.

    Here is what an entry in my external LDAP directory looks like:

    dn: uid=user,ou=People, dc=company,dc=com
    mail: user@company.com
    uid: user

    And an ldap search with this:

    ldapsearch -b "dc=company,dc=com" -D "directory manager" -w password "uid=user"

    returns the user entry.

    Here are the entries used for external authentication:

    LDAP Url: ldap://ldap.company.com:389/
    LDAP Filter: (uid=%u) or (mail=%n)
    LDAP Base Search: ou=People,dc=company,dc=com
    Bind DN: cn=directory manager
    Bind DN Password: password

    which give successful test results.

    If it matters, Zimbra is running on FC4 x86.

    Any help would be appreciated.

  2. #2
    Join Date
    Feb 2006
    Posts
    2
    Rep Power
    9

    Default Forgot Zimbra Version

    I forgot to post the Zimbra version.

    I'm using Zimbra Beta 3 Open Source, downloaded today.

  3. #3
    Join Date
    Nov 2005
    Posts
    12
    Rep Power
    9

    Default

    that is strange..

    I'm using FDS for 3 months now with zimbra and 25 branches of domains and it works perfectly.

    A good thing for admin is to have the basic zimbra installed on host.mydomain.com and keep the admin as internal and then, configure another domain as simply mydomain.com to configure the standard accounts.

    Also, making a "tail -f" of FDS log in realtime while login should let you diagnose almost any/all FDS auth problems.

    --jeff

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    You'll also want to setup fallback so the admin account will still work. This will keep you from needing to create a seperate domain just for the admin.

    http://www.zimbra.com/forums/showthr...light=fallback
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    May 2006
    Posts
    81
    Rep Power
    9

    Default

    Jemerson , did you solve this problem ? ... I have the same problem .

Similar Threads

  1. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  2. External LDAP Problem
    By facerw in forum Installation
    Replies: 7
    Last Post: 05-08-2007, 04:29 AM
  3. External LDAP Authentication Issue
    By xtreme-one in forum Installation
    Replies: 10
    Last Post: 02-16-2007, 06:52 PM
  4. Authentication to external ldap stop working.
    By jahaj in forum Installation
    Replies: 3
    Last Post: 12-05-2006, 02:17 PM
  5. Replies: 7
    Last Post: 04-14-2006, 01:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •