Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: CalDav Issue with Leopard

  1. #1
    Join Date
    Nov 2007
    Posts
    10
    Rep Power
    7

    Default CalDav Issue with Leopard

    Hey all,
    I'm thinking this might be a firewall issue, but I'm trying to get my CalDav integration working with Leopard based off the blog post today.
    When I try to set up the connection, I get the following error:

    Unexpected secure name resolution error (code -9813). The server name <zimbra server> may be incorrect.

    Now I can connect to my Zimbra server just fine over https to use webmail. I'm assuming that CalDav uses the same port for that? I looked up the error in the forums and didn't see it.

    Thanks ahead of time,
    CdtDelta

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    hi CDT
    Are you using any sort of proxying? CalDav is on what ever your http port is, so if you're using https be sure to put https in the box..

    Anything in the /opt/zimbra/log/zmmailboxd.out file?

  3. #3
    Join Date
    Nov 2007
    Posts
    10
    Rep Power
    7

    Default

    Nope, just a firewall. I am using https only actually with the server. If I use http I'll get a port blocked error (or something like that).

    There's nothing in the log file (and I mean there's nothing in the log file).

    Is there an easy way to check the Zimbra version I'm running? I'm wondering if I ever upgraded to 5.0.2.

  4. #4
    Join Date
    Apr 2007
    Location
    Los Gatos, CA
    Posts
    138
    Rep Power
    8

    Default

    iCal on Leopard works great with Zimbra v5. In iCal, setup the account url like this:

    https://yourmailserverhostname/princ...sers/cdtdelta/

    Make sure the hostname is a FQDN.

  5. #5
    Join Date
    Nov 2007
    Posts
    10
    Rep Power
    7

    Default

    Ok well I updated to 5.0.2 and tried it again, still no joy. I am using the Open Source version if that makes a difference.
    Is there something I need to enable on the Zimbra server in order to use CalDav? Or is it enabled by default?

    Just looked at the logs on my Mac, and it's showing this when I try to connect:

    Mar 18 13:20:16 Slave-1 iCal[597]: [DAVRequest _readStreamEvent]: SecTrustEvaluate failed. Failing with error: Error Domain=NSStreamSocketSSLErrorDomain Code=-9813 "Operation could not be completed. (NSStreamSocketSSLErrorDomain error -9813.)"
    Mar 18 13:20:18 Slave-1 iCal[597]: *** -[NSLock dealloc]: lock (<NSLock: 0x16a19e00> '(null)') deallocated while still in use
    Mar 18 13:20:18 Slave-1 iCal[597]: *** Break on _NSLockError() to debug.
    Last edited by CdtDelta; 03-18-2008 at 11:21 AM.

  6. #6
    Join Date
    Apr 2007
    Location
    Los Gatos, CA
    Posts
    138
    Rep Power
    8

    Default

    Quote Originally Posted by CdtDelta View Post
    Ok well I updated to 5.0.2 and tried it again, still no joy. I am using the Open Source version if that makes a difference.
    Is there something I need to enable on the Zimbra server in order to use CalDav? Or is it enabled by default?

    Just looked at the logs on my Mac, and it's showing this when I try to connect:

    Mar 18 13:20:16 Slave-1 iCal[597]: [DAVRequest _readStreamEvent]: SecTrustEvaluate failed. Failing with error: Error Domain=NSStreamSocketSSLErrorDomain Code=-9813 "Operation could not be completed. (NSStreamSocketSSLErrorDomain error -9813.)"
    Mar 18 13:20:18 Slave-1 iCal[597]: *** -[NSLock dealloc]: lock (<NSLock: 0x16a19e00> '(null)') deallocated while still in use
    Mar 18 13:20:18 Slave-1 iCal[597]: *** Break on _NSLockError() to debug.
    are your certificates okay? did you attempt to install a commercial cert and/or move a commercial cert from one server to another? if so, try reinstalling the certs manually. did you set zmtlsctl to redirect?

    on another note, try Sunbird and see if you get the same errors. use both http & https.

  7. #7
    Join Date
    Nov 2007
    Posts
    10
    Rep Power
    7

    Default

    Quote Originally Posted by danielfarrelly View Post
    are your certificates okay? did you attempt to install a commercial cert and/or move a commercial cert from one server to another? if so, try reinstalling the certs manually. did you set zmtlsctl to redirect?

    on another note, try Sunbird and see if you get the same errors. use both http & https.
    Nope, didn't touch certificates at all. I only have one server, this is for my personal mail (so there are only like three accounts on it).
    No I did not set zmtlsctl to redirect. My server is set up for https only, and that's what I'm typing in the settings for iCal. I get a "connection refused" if I use http only.

  8. #8
    Join Date
    Apr 2007
    Location
    Los Gatos, CA
    Posts
    138
    Rep Power
    8

    Default

    we can maybe try some basic stuff. nmap and see what ports are open. what version of OS X are you running? amount of ram, processor, etc. do you have a fqdn and mx record pointing directly to an IP, or are you using a proxy of some sort. have you created any calendars other than the default "calendar"?

  9. #9
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Are you able to use iCal against the hosted demo?

  10. #10
    Join Date
    Feb 2008
    Location
    Minot, ND
    Posts
    13
    Rep Power
    7

    Default

    I'd like to chime in and state that I'm having this very same issue, sans firewall. I'm on my local network with nothing between and getting the same error if I try to connect via https. If I try connecting via http, I can connect, but get a different error that warrants a thread of its own.

    The particulars:

    Release 5.0.4_GA_2101.RHEL5_64_20080321154100 CentOS5_64 FOSS edition

    Mac OS X 10.5.2 - iCal 3.0.2

Similar Threads

  1. iCal caldav error in 5.0.1 NE
    By frankske in forum Users
    Replies: 5
    Last Post: 06-03-2008, 07:35 AM
  2. problem with caldav and leopard
    By jurg in forum Administrators
    Replies: 16
    Last Post: 05-05-2008, 11:48 AM
  3. Replies: 5
    Last Post: 03-28-2008, 10:39 AM
  4. Shared calendars, iCal (leopard) and caldav
    By dazole2 in forum Administrators
    Replies: 9
    Last Post: 03-26-2008, 10:52 AM
  5. Intermittent issue (issue# 5852) ?
    By nick20 in forum Installation
    Replies: 1
    Last Post: 02-08-2006, 01:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •