Results 1 to 3 of 3

Thread: Address book problem zim 4.5.6

Hybrid View

  1. #1
    Join Date
    Jul 2007
    Rep Power

    Default Address book problem zim 4.5.6

    I'm using zimbra 4.5.6 GA which I would like to upgrade. I am currently having an address book issue which I need to fix before I begin the upgrade process.

    Here is what happened. I imported a thunderbird csv file as an address book for one user. The import completed successfully, but all the data was bad, because the column layout was different from what zimbra was expecting (yes I know, I should have looked first). I deleted all the entries from that address book (in the zimbra web interface).

    Then I an empty address book (exported from zimbra). I copied the data from the thunderbird csv, into the correct location in the empty csv, and re-imported. This also completed successfully, but I noticed that the data was botched up again. This time it is in the right format, but the names and email addresses do not match or line up correctly.

    I delete all the entries again. The web interface shows that there are no entries in the address book. When I check the mail for this user, it will say for example that an email was CC'ed to user "Dan <Joe@domain.tld>". The email headers will show that it should have been delivered to "Joe <joe@domain.tld>". Logging in and out, and even from other computers, did not fix this problem. Zimbra is constantly displaying the wrong names with the email addresses. As a temporary solution, I disabled the users ability to use address books, which worked.

    I would like to know how to fix this problem before I upgrade. I can't seem to find where the address book is really located, and certainly cannot figure out how to delete the data that is in it. Any thoughts.?

  2. #2
    Join Date
    Oct 2005
    Thatcher, AZ
    Rep Power


    What I would do?

    Upgrade to 5.0
    su - zimbra
    sm (e-mail address)
    ef /Contacts
    Fix your csv, then reimport

  3. #3
    Join Date
    Jul 2007
    Rep Power


    I took a look in zmprov. It looks like that folder is already empty.


    prov> sm *************
    mailbox: *************, size: 6.52 GB, messages: 77978, unread: 9937
    mbox *************> gaf
            Id  View      Unread   Msg Count  Path
    ----------  ----  ----------  ----------  ----------
             7  cont           0           0  /Contacts

Similar Threads

  1. Adding Contacts to a Shared Address Book problems
    By chalkboy in forum Administrators
    Replies: 9
    Last Post: 01-10-2008, 12:13 AM
  2. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 06:07 PM
  3. Replies: 6
    Last Post: 09-26-2007, 12:38 PM
  4. [SOLVED] Zimbra not syncing properly with Address Book and iCal
    By Colin Day in forum CalDAV / CardDAV / iSync
    Replies: 4
    Last Post: 07-13-2007, 08:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts