Results 1 to 2 of 2

Thread: Creating archives on a specific server

  1. #1
    Join Date
    Feb 2006
    Location
    Newcastle, UK
    Posts
    17
    Rep Power
    9

    Default Creating archives on a specific server

    Hi All,

    I've not been able to figure out why this happens. I've been merrily configuring archives using A&D for my users, but for some reason, I can't tell it where to create the archives. I want to create the archives on the same server as the normal mailbox resides, but no matter how I go about it, zmarchiveconfig will always choose the least appropriate server* to host the archives. I've tried specifying a server hostname (although I assume this just actions the request on a particular server via SOAP). I've also tried creating a COS for the archives, and defining a single usable server in the COS, but it seems to ignore that too.

    At the minute, I'm having to let it create the archive, locate the server it's been created on, and zmmailboxmove to the server it should be on. I need to be quick about this process, too; if it starts delivering mail to the archive before I shift it, chances are I'll just get a SOAP error...

    Am I doing something wrong, or is there something amiss here?

    Cheers,

    Kev

    * I'm sure it's not doing it on purpose, but I have three "satellite" servers sitting out on sites with the least amount of bandwidth back to the rest of the world and it usually picks on of those.

    PS. Is there no way to enable an archive account for all mailboxes in one easy command?

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    I don't know of one command (most just repeat the zmarchiveconfig enable <user@domain> archive-cos <cos>) but I've attached a shell script that will search for accounts with archiving not enabled yet and turn it on. Might want to test on a devel box first so you know exactly how it's going to perform.

    Don't know why it's not respecting your chosen server pool in COS - is this still 5.0.1? -from your profile
    (Good RFE for allowing zmarchiveconfig to allow direct setting of zimbraMailHost etc on creation.)

    Could you elaborate on your zmmailboxmove error? There was: Bug 24562 - zmmailboxmove fails with IO error on 5.0.2.

    http://www.zimbra.com/forums/announc...5-0-3-out.html
    Attached Files Attached Files

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. 4.0.4 to 4.5.6 upgrade failed in network edition
    By chenthil in forum Administrators
    Replies: 1
    Last Post: 08-27-2007, 10:36 AM
  3. [SOLVED] Simple backup question...
    By dameron in forum Administrators
    Replies: 3
    Last Post: 08-25-2007, 10:36 PM
  4. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •