Results 1 to 2 of 2

Thread: zmmailbox commands to subscribe a calendar to an ical feed changed or broken

  1. #1
    Join Date
    Sep 2007
    Posts
    4
    Rep Power
    8

    Default zmmailbox commands to subscribe a calendar to an ical feed changed or broken

    Hi Folks,

    We've recently upgraded to Zimbra 5.0.4 and I've noticed that following commands I was using to create a new calendar and subscribe it to an ical feed no longer work:

    zmmailbox -z -m some_user cf --view appointment --color cyan --flags "#" "/SubscribedCalendar"

    zmmailbox -z -m some_user mfu "/SubscribedCalendar" "http://address_to/feed.ics"

    The calendar creation works as it had, but when I attempt to add the url to the calendar it fails with:

    ERROR: mail.CANNOT_SUBSCRIBE (cannot add subscription to existing folder 92190)

    It looks like "importURLIntoFolder" should do something similar and when I try:

    zmmailbox -z -m some_user iuif "/SubscribedCalendar" "http://address_to/feed.ics"

    it appears to succeed (there's no error message), but doing a:

    getFolder "/SubscribedCalendar"

    shows the "url:" field still blank.

    Any ideas what the appropriate way to do this is now?

    Thanks,
    Matt Bockol
    Web Technical Administrator
    Carleton College

  2. #2
    Join Date
    Sep 2007
    Posts
    4
    Rep Power
    8

    Default nevermind ...

    I spotted the bug report here

    Bug 14840 - mail.CANNOT_SUBSCRIBE when trying to change the URL on a calendar folder

    and see that you must assign an initial url with the --url flag when doing the createFolder command.

    Thanks,
    Matt

Similar Threads

  1. Changing Calendar Organizer script
    By snsparrish in forum Administrators
    Replies: 4
    Last Post: 05-02-2011, 05:41 AM
  2. Publish calendar from iCal (Leopard) to Zimbra
    By gero in forum Administrators
    Replies: 2
    Last Post: 09-29-2008, 02:03 PM
  3. 5.0 Install tasks
    By JoshuaPrismon in forum Installation
    Replies: 2
    Last Post: 06-06-2007, 01:18 PM
  4. httpd resident in memory but not accessible
    By AlexanderH in forum Installation
    Replies: 3
    Last Post: 05-11-2007, 10:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •