Results 1 to 2 of 2

Thread: LDAP Replication Install

  1. #1
    Join Date
    Aug 2006
    Posts
    28
    Rep Power
    9

    Default LDAP Replication Install

    I'm attempting to get LDAP replication working between two servers. The master (san-zldap2) is 5.0.2 and the replica (san-zldap1) is 5.0.4. (Yes the names are backwards) Is that possible or do I need to upgrade the master first? When I try to run a zmupdateauthkeys on the master I get the following error:

    updating san-zldap1.officeondemand.com
    Fetching key for san-zldap1.officeondemand.com
    Key for san-zldap1.officeondemand.com NOT FOUND

    Then I try to create the key on san-zldap1 and this happens:

    [zimbra@san-zldap1 ~]$ zmsshkeygen
    Generating public/private dsa key pair.
    Your identification has been saved in /opt/zimbra/.ssh/zimbra_identity.
    Your public key has been saved in /opt/zimbra/.ssh/zimbra_identity.pub.
    The key fingerprint is:
    90:75:80:f0:2c:7b:c7:32:f9:56:51:3d:2a:9c:a6:6a san-zldap1.officeondemand.com
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])

    Is this a cert problem or a version error? Not sure why that would happen the passwords are all the same.

  2. #2
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    Quote Originally Posted by freefall View Post
    Not sure why that would happen the passwords are all the same.
    Look at the values for the ldap password settings in zmlocalconfig -s on both servers. In particular, the passwords set for:

    zimbra_ldap_password
    ldap_root_password

    They should be identical on both the master and slave.

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Similar Threads

  1. LDAP Replication Experiences
    By technikolor in forum Administrators
    Replies: 4
    Last Post: 11-12-2008, 12:52 AM
  2. Multi Server Installation
    By rsharpe in forum Installation
    Replies: 6
    Last Post: 07-11-2007, 10:53 PM
  3. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM
  4. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 03:39 PM
  5. LDAP Replication
    By rsharpe in forum Installation
    Replies: 3
    Last Post: 02-28-2006, 07:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •