Results 1 to 10 of 10

Thread: How to queue outgoing messages

  1. #1
    Join Date
    Mar 2008
    Posts
    6
    Rep Power
    7

    Default How to queue outgoing messages

    I have installed Zimbra and replaced our previous sendmail/cyrus/pine combination.

    We are very pleased with Zimbra, but have one issue.

    It appears that when you hit send from the webmail, zimbra waits for the SMTP transaction to complete before closing the compose window. In some cases, such as sending to Yahoo! the remote mail server may be unavailable or request that the message be deferred (example below). In the old sendmail world, the message would get queued and sendmail would retry. I cannot seem to find this option in Zimbra.

    How do i tell Zimbra if at first try you do not succeed, try again until success; if after a period of failures then report to the sender....

    Here is the message that pops up when there is a failure:

    msg: SMTP server reported: 450 4.1.1 : Recipient address rejected: unverified address: host f.mx.mail.yahoo.com[209.191.88.247] refused to talk to me: 421 Message from (pub.lic.ip.addr) temporarily deferred - 4.16.50. Please refer to http://help.yahoo.com/help/us/mail/defer/defe.

    The error log shows:

    Apr 10 13:44:38 mail postfix/smtpd[27035]: NOQUEUE: reject: RCPT from localhost.localdomain[127.0.0.1]: 450 4.1.1 <rcptAddr@yahoo.com>: Recipient address rejected: unverified address: host f.mx.mail.yahoo.com[209.191.88.247] refused to talk to me: 421 Message from (pub.lic.ip.addr) temporarily deferred - 4.16.50. Please refer to http://help.yahoo.com/help/us/mail/defer/defer-06.html; from=<sender@domain.com> to=<rcptAddr@yahoo.com> proto=ESMTP helo=<mail.domain.com>


    Any thoughts or help would be greatly appreciated. As an aside 5 hours later the message was accepted by yahoo for delivery, but we had to keep it in draft and manually resend. It would be better to resubmit it and let Zimbra try to resend, i am sure there is a checkbox i am missing somwhere-

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    That what happens is, briefly, zimbra processes your email then forwards it to Postfix for delivery. All mail delivery and resending is handled by postfix, you don't need to keep the mail in draft and resend.

    When you say the message 'pops-up' when there is a failure, what do you mean by that? There should be no pop-up message of that type, it should appear in the logs and not pop-up.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Mar 2008
    Posts
    6
    Rep Power
    7

    Default

    Thank you for your reply.

    That is what i would expect, postfix to handle the retries and such, however it seems that zimbra waits for the SMTP transaction to complete.

    I hit send, and a box comes up with an ! and the text "Could not send message: mail.SEND_FAILURE"

    Options of the alert box are "send error report" or "show details". If i show details, it quotes the logs as i showed in the previous post. Is there a postfix configuration that needs to be toggled so that postfix will queue the message and retry, like i mentioned i am new to using posftix as the mta.

    The error is infrequent, but is annoying when it does happen. For example i can have a To/CC list of 10 addresses. If one of them fails, the message pops up and i cannot send the message.

    -Timur

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    That would indicate you have some issue connecting to your Zimbra server, it's not (IIRC) connected with mail delivery by postfix. What else is in the log files around the time this message happens?

    Which version/release of Zimbra is this and which operating system?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Mar 2008
    Posts
    6
    Rep Power
    7

    Default

    Oh, it is a RHEL 5 running Zimbra 5.0.2 open source (zcs-5.0.2_GA_1975.RHEL5.20080130221917.tgz)

    > uname -a
    Linux mail.domain.com 2.6.18-53.el5 #1 SMP Wed Oct 10 16:34:02 EDT 2007 i686 i686 i386 GNU/Linux

  6. #6
    Join Date
    Mar 2008
    Posts
    6
    Rep Power
    7

    Default

    It looks like the extended logs did not post but the second did 2x.... I could call you or skype you if it is more convenient. It seems odd to me the NOQUEUE as opposed to a mail ID and while i understand why, it appears odd to see the localhost.localdomain listed there too....

    The zimbra log show:
    Apr 10 14:07:39 mail postfix/smtpd[2689]: connect from localhost.localdomain[127.0.0.1]
    Apr 10 14:07:39 mail postfix/smtpd[2689]: NOQUEUE: reject: RCPT from localhost.localdomain[127.0.0.1]: 450 4.1.1 <rcpt@yahoo.com>: Recipient address rejected: unverified address: host f.mx.mail.yahoo.com[209.191.88.247] refused to talk to me: 421 Message from (64.68.128.74) temporarily deferred - 4.16.50. Please refer to http://help.yahoo.com/help/us/mail/defer/defer-06.html; from=<timur@domain.com> to=<rcpt@yahoo.com> proto=ESMTP helo=<mail.domain.com>
    Apr 10 14:07:39 mail postfix/smtpd[2689]: disconnect from localhost.localdomain[127.0.0.1]

    maillog:
    Apr 10 14:07:39 mail postfix/smtpd[2689]: connect from localhost.localdomain[127.0.0.1]
    Apr 10 14:07:39 mail postfix/smtpd[2689]: NOQUEUE: reject: RCPT from localhost.localdomain[127.0.0.1]: 450 4.1.1 <rcpt@yahoo.com>: Recipient address rejected: unverified address: host f.mx.mail.yahoo.com[209.191.88.247] refused to talk to me: 421 Message from (64.68.128.74) temporarily deferred - 4.16.50. Please refer to http://help.yahoo.com/help/us/mail/defer/defer-06.html; from=<timur@domain.com> to=<rcpt@yahoo.com> proto=ESMTP helo=<mail.domain.com>
    Apr 10 14:07:39 mail postfix/smtpd[2689]: disconnect from localhost.localdomain[127.0.0.1]

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by timur View Post
    It looks like the extended logs did not post but the second did 2x....
    It's a moderation system to stop spammers, it holds it for approval if you're a new member and it contains a url.

    Let's check a couple of things before we go any further. Is this a new install? Is this server behind a NAT device? Do you have a split DNS set-up? Can you run the following commands on the zimbra server:

    Code:
    host `hostname`  <-- use backticks not single quotes
    dig yourdomain.com mx
    dig yourdomain.com any
    and post the results.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Mar 2008
    Posts
    6
    Rep Power
    7

    Default

    There is no nat. The server is on publically addressable ip space. The install was done Mar 11.

    I did first install it on a NAT ip address (192.168.1.x), got the server running then changed the IP of the server to the public space. This was so we could transfer the messages from our current mail server to a tmp space, then copy them to the zimbra server. We then took the legacy server offline, brought the zimbra up and began using it.

    # host `hostname`
    mail.fileyourtaxes.com has address 64.68.128.74



    # dig mail.fileyourtaxes.com mx

    ; <<>> DiG 9.3.3rc2 <<>> mail.fileyourtaxes.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21438
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mail.fileyourtaxes.com. IN MX

    ;; AUTHORITY SECTION:
    fileyourtaxes.com. 43200 IN SOA ns1.fileyourtaxes.com. hostmaster.fileyourtaxes.com. 2008011001 43200 1800 604800 43200

    ;; Query time: 18 msec
    ;; SERVER: 207.71.201.225#53(207.71.201.225)
    ;; WHEN: Fri Apr 11 00:45:27 2008
    ;; MSG SIZE rcvd: 91




    # dig mail.fileyourtaxes.com any

    ; <<>> DiG 9.3.3rc2 <<>> mail.fileyourtaxes.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52900
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;mail.fileyourtaxes.com. IN ANY

    ;; ANSWER SECTION:
    mail.fileyourtaxes.com. 43200 IN A 64.68.128.74

    ;; AUTHORITY SECTION:
    fileyourtaxes.com. 43200 IN NS mail.bopfer.com.
    fileyourtaxes.com. 43200 IN NS ns1.fileyourtaxes.com.
    fileyourtaxes.com. 43200 IN NS ns2.fileyourtaxes.com.

    ;; ADDITIONAL SECTION:
    ns1.fileyourtaxes.com. 43200 IN A 207.71.201.225
    ns2.fileyourtaxes.com. 43200 IN A 64.68.128.75

    ;; Query time: 19 msec
    ;; SERVER: 207.71.201.225#53(207.71.201.225)
    ;; WHEN: Fri Apr 11 00:45:39 2008
    ;; MSG SIZE rcvd: 150

    #

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You've used the wrong command to check your DNS, it should be the following:

    Code:
    dig fileyourtaxes.com mx
    dig fileyourtaxes.com any
    While we are at it, what does the following command show:

    Code:
    su - zimbra
    postconf mynetworks
    post the output.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    Join Date
    Mar 2008
    Posts
    6
    Rep Power
    7

    Default Soultion found

    It appears it was not a DNS error, but this was the solution:

    http://www.zimbra.com/forums/adminis...-progress.html

    Thanks for your help. You may want to add the keyword search "address verification in progress" to the above forum, as that is the message I kept getting, but it did not appear in my searches-

Similar Threads

  1. [SOLVED] Re-creating the spam training e-mail account
    By richard-hdd in forum Administrators
    Replies: 21
    Last Post: 03-20-2012, 07:34 AM
  2. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  3. queue problem w/ deferred messages
    By alderion in forum Administrators
    Replies: 10
    Last Post: 10-26-2006, 07:51 AM
  4. Spam assassain not traiing properly!
    By Mike T in forum Administrators
    Replies: 1
    Last Post: 10-09-2006, 01:34 PM
  5. Replies: 1
    Last Post: 07-27-2006, 06:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •