Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: [SOLVED] Problem With zmlocalconfig -e and Postfix smtpd_banner Variable

  1. #1
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default [SOLVED] Problem With zmlocalconfig -e and Postfix smtpd_banner Variable

    The lawyers tell us we need to add "NO UCE" to the Postfix smtpd_banner string.

    On ZCS 4.5.x, this was easy by using the postconf -e command.

    Now on ZCS 5, we need to use the zmlocalconfig -e command.

    OK, except either zmlocalconfig doesn't want to do this one or I've got the syntax wrong:

    zimbra@ourserver:~> zmlocalconfig -e postfix_smtpd_banner = $myhostname NO UCE ESMTP
    Error: argument 'postfix_smtpd_banner' not in key=value form
    zimbra@ourserver:~> zmlocalconfig -e postfix_smtpd_banner=$myhostname NO UCE ESMTP
    Error: argument 'NO' not in key=value form

    I did in fact read the Administrator's Guide prior to posting here :-) and I notice two things:

    First, the "-e" option for zmlocalconfig isn't even mentioned on page 172.

    Second, running "zmlocalconfig -h" at least shows the "-e" option, but doesn't give me any help (that I can see) as to why I can't make the change above.

    Any ideas? Do I need to fill out a bug report on this one?

    Thanks!
    Mark

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Code:
    zmlocalconfig -e postfix_smtpd_banner="\$myhostname NO UCE ESMTP"
    should work better for you $myhostname is being expanded by the shell, and not put in the string as a variable, so you need to escape it out. Also as you are entering multiple words these need to be wrapped with quotes. If you want to change it without reloading all the services you can also do :-
    Code:
    postconf -e smtpd_banner="\$myhostname NO UCE ESMTP"
    zmmtactl reload

  3. #3
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default

    Thanks uxbod for the syntax usage tricks!

    That did it!

    All the best,
    Mark

  4. #4
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default

    Quote Originally Posted by uxbod View Post
    Code:
    zmlocalconfig -e postfix_smtpd_banner="\$myhostname NO UCE ESMTP"
    should work better for you $myhostname is being expanded by the shell, and not put in the string as a variable, so you need to escape it out. Also as you are entering multiple words these need to be wrapped with quotes. If you want to change it without reloading all the services you can also do :-
    Code:
    postconf -e smtpd_banner="\$myhostname NO UCE ESMTP"
    zmmtactl reload
    FWIW this did NOT survive the upgrade to 5.0.5.

  5. #5
    Join Date
    Feb 2010
    Location
    South Africa
    Posts
    107
    Rep Power
    5

    Default

    I tried the following:
    zmlocalconfig -e postfix_smtpd_banner="mail.mydomain.co.za NO UCE ESMTP"
    postconf -e smtpd_banner="mail.mydomain.co.za NO UCE ESMTP"
    zmmtactl reload
    zmprov mcf zimbraMtaMyHostname mail.mydomain.co.za
    zmcontrol stop
    zmcontrol start

    But:
    telnet mail.mydomain.co.za 25
    220 *****************************************
    HELO me
    250 mail.mydomain.co.za
    quit

    The asterisks are as-is in the telnet window, why is it not displaying the 'real' banner here?

    Disclaimer: Domain names have been changed to protect the innocent, any similarity to domains living or dead is purely coincidental and, etc. etc.

  6. #6
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default

    We have gotten advice that we don't need to update the banner anymore, so we don't.

    But out of curiosity, if you run as root the following command, what does it show?

    /opt/zimbra/postfix/sbin/postconf -n | grep banner

    All the best,
    Mark

  7. #7
    Join Date
    Feb 2010
    Location
    South Africa
    Posts
    107
    Rep Power
    5

    Default

    Thank you for your response.
    Running that command gives the proper banner. Myself (and management) use mxtoolbox.com to do an SMTP test which gives a warning that the reverse DNS does not match the banner. Also telnetting to the server on port 25 gives the ***** banner. Mail is working fine, but I suppose it might increase our spam scoring on some servers? Having said that, my other Zimbra installations have public IPs and the banner work fine, this one use private IPs natted as it is a DRBD/Heartbeat install so I do not know if there is something that I did wrongfully to bring this upon me.
    Ekkas

  8. #8
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default

    The intricacies of your setup are not clear to me, but you may want to look at the proxy_interfaces Postfix configuration parameter details in the documentation section at The Postfix Home Page to see if that applies to you.

    Also, if you do not have any PTR record, you will have problems. Ideally, the PTR record should match the fqdn, but it's most important that there be a PTR record of some sort in place.

    Hope that helps,
    Mark

  9. #9
    Join Date
    Feb 2010
    Location
    South Africa
    Posts
    107
    Rep Power
    5

    Default

    Yes thanks, we have a PTR which match the FQDN but not the banner which is what mxtoolbox.com is warning us about. I also manually edited the main.cf file in Postfix config, but the banner is still throwing a bunch of stars at me. If they were golden stars it might have brought back pleasant memories of kindergarten, but the telnet interface colours do not do it justice. ;-)

    I'll have a look at the Postfix documentation when I have some more time, but the white rabbit is contantly calling me, pointing to his watch. (No I didn't smoke something, but that last cup of coffee did taste a bit strange)
    I'll post here if I find the fix for future reference.

    Thank you very much for your interest and help.
    Ekkas

  10. #10
    Join Date
    May 2010
    Posts
    19
    Rep Power
    0

    Default

    ~~~~~~~~~~~~~ 4h before~~~~~~~~~~~~~~~~~~~~~
    Hi there

    I got the same warning from mxtoolbox too. My smtpd banner always 220 ******************** after I tried all your suggestions.

    I'm using ZCS 6.0.7.

    ~~~~~~~~~~~~~ And now ~~~~~~~~~~~~~~~~~~~~~

    I discovered the firewall in our system filter esmtp-banner. After they permit, it runs well

    Thanks
    Last edited by lmthong; 11-17-2010 at 01:32 AM.

Similar Threads

  1. postdrop fail to create file after upgrade to 5.0.3
    By echoadisan in forum Installation
    Replies: 23
    Last Post: 07-15-2013, 03:02 PM
  2. postfix tls problem on mandriva 2007
    By dkn in forum Installation
    Replies: 3
    Last Post: 12-31-2007, 02:27 PM
  3. Replies: 3
    Last Post: 11-03-2007, 10:55 PM
  4. Problem with Postfix on Ubuntu
    By kgmeyer in forum Installation
    Replies: 6
    Last Post: 01-22-2007, 03:49 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •