Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: [SOLVED] Firefox 3 + Zimbra 5 - TLS Interop issue

  1. #21
    Join Date
    Jun 2008
    Posts
    5
    Rep Power
    7

    Default

    Quote Originally Posted by p24t View Post
    I have no more issues as of updating to 5.0.6. Whichever it is, it's been solved.
    We are running 5.0.5, so that might be it... We'll schedule an upgrade, needs to be done really anyway.

    Thanks. If it still happens, I'll post here again.

  2. #22
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    To wrap up this thread:

    FF3 attempts to use TLS first when making an https connection, but the SslEngine in Java6 does not appear to handle this and simply times out before FF3 falls back to normal SSL.

    A switch to JDK 1.5 while running Zimbra 5.0.4/.5, or upgrade to 5.0.6+ (which uses JDK1.5 intentionally) resolves the issue (5.0.8 is current).

    We ran JDK1.6 till 5.0.5, and we downgraded for 5.0.6 to avoid 3 Sun bugs:
    Bug ID: 6614100 EXCEPTION_ACCESS_VIOLATION while running Eclipse with 1.6.0_05-ea - fixed
    Bug ID: 6546278 Synchronization problem in the pseudo memory barrier code - fixed
    Bug ID: 6693490 (se) select throws "File exists" IOException under load (lnx) - still open but fix planned

    Recent convo on those: http://www.zimbra.com/forums/administrators/20189-testing-jdk-1-6-x-zimbra-5-0-x.html (notes this TLS issue is still prevalent in JDK 1.6u7)
    While we do have a few customers who have also gone back to JDK1.6 for one reason or another because they have modifications that depend on it, I would run NE with what we build/support - if you must upgrade them please notify support whenever you/they open tickets that it's using JDK1.6

    Bug 13487 – Upgrade to JDK 1.6 for 5.0.x series, then Bug 27890 – Downgrade to JDK 1.5.0_15 for 5.0.6

    Tools > options > advanced > encryption > uncheck TLS 1.0 if you're really curious to test the difference using FF3 against JDK1.6
    Though it's not exactly something you want to have to do on a mass of users & it's enabled by default for a reason.


    More: [#JETTY-567] Delay in initial TLS Handshake With FireFox 3 beta5 and SslSelectChannelConnector - jira.codehaus.org

    This is filed for tracking/retesting whenever we officially upgrade to JDK1.6: Bug 29631 – delay loading login page when using Firefox 3 over SSL/TLS

    Tools > options > advanced > encryption > uncheck TLS 1.0 if you're really curious to test the difference using FF3 against JDK1.6
    Though it's not exactly something you want to have to do on a mass of users & it's enabled by default for a reason.

Similar Threads

  1. admin consol blank after 5.0.3 upgarde
    By maumar in forum Administrators
    Replies: 6
    Last Post: 03-21-2008, 06:16 AM
  2. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  3. Replies: 12
    Last Post: 02-24-2008, 12:16 AM
  4. zimbra-core missing
    By kinaole in forum Developers
    Replies: 1
    Last Post: 10-02-2006, 12:59 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 05:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •