Results 1 to 10 of 10

Thread: transport unavailable

Hybrid View

  1. #1
    Join Date
    Nov 2006
    Location
    Minneapolis, MN
    Posts
    101
    Rep Power
    9

    Default transport unavailable

    What might be causing this batch of errors in zimbra.log...and all incoming messages to be put into deferred queue?
    Apr 17 10:46:26 smtp postfix/smtp[3632]: 78242FC8F0: to=<shannons@creative-lighting.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.65, delays=0.06/0/0/0.58, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 16E8EFC907)
    Apr 17 10:46:26 smtp postfix/smtp[3632]: 78242FC8F0: to=<tammy@creative-lighting.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.65, delays=0.06/0/0/0.58, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 16E8EFC907)
    Apr 17 10:46:26 smtp postfix/qmgr[6252]: 78242FC8F0: removed
    Apr 17 10:46:26 smtp postfix/qmgr[6252]: warning: connect to transport retry: No such file or directory
    Apr 17 10:46:26 smtp postfix/qmgr[6252]: 16E8EFC907: to=<brendad@creative-lighting.com>, relay=none, delay=0.08, delays=0.02/0.06/0/0, dsn=4.3.0, status=deferred (mail transport unavailable)

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Code:
    su - zimbra
    zmcontrol status
    please

  3. #3
    Join Date
    Nov 2006
    Location
    Minneapolis, MN
    Posts
    101
    Rep Power
    9

    Default

    OK, here are some coincedences. (ZCS 5.0.4.NE evaluation, Ubuntu 6.06LTS)
    I have one user with 16000 sent items, 10000 Inbox.
    I connected to Zimbra server IMAP (Thunderbird, WinXP), as this user.
    As Sent folder loaded, I got timeout, and IMAP refused to connect again.

    At that point, all messages started showing up in deferred queue in Admin UI.
    (zmcontrol status: all running)
    (This is a repeat of a very similar incident Tues (15-April). Same user, same IMAP, same symptoms.)

    Restarted whole Linux box.
    Messages all delivered, with that timestamp, of the minute the serverBox rebooted.

    This deferred/IMAP thing is really strange.

    Any thoughts?
    thanks,
    rick

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Could you check your other Log Files - Zimbra :: Wiki for errors aswell please. Especially ones about the mail storage. Perhaps problems with their IMAP folder, could try a re-index from the Admin GUI for good measure, but I guess that is not required.

  5. #5
    Join Date
    Nov 2006
    Location
    Minneapolis, MN
    Posts
    101
    Rep Power
    9

    Default

    Quote Originally Posted by uxbod View Post
    Could you check your other Log Files - Zimbra :: Wiki for errors aswell please. Especially ones about the mail storage. Perhaps problems with their IMAP folder, could try a re-index from the Admin GUI for good measure, but I guess that is not required.
    I will look at the wiki for other logs to check. I had been tailing these two:
    /var/log/zimbra.log
    /opt/zimbra/log/mailbox.log

    I have NOT done an index for this user since I reimported all his messages from a hosted IMAP server elsewhere...Interesting thought. Probably won't do that today during business.
    And the only reason that I've been IMAPping at all, is to bring in user's messages from this temporary mail host.
    If Zimbra is approved by the boss (this 'big' mailbox...wish us luck then we will likely not open up IMAP for anyone anyway, period.


    I have had too many scary moments during this process, after a big crash 25-March. Still jittery when things don't act politely. (I'll leave IMAP alone, and see if things behave from here out).
    Thanks!
    rick

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Just an idle comment here (and possibly nothing to do with your problem), I find it strange that a dig for 'any' on your domain resolves in 1ms and the one for 'mx' takes 169ms - that really is a hell of a difference. Have you considered moving the DNS server to another machine?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Nov 2006
    Location
    Minneapolis, MN
    Posts
    101
    Rep Power
    9

    Default

    We are aware of some challenges that I've been having with the split DNS, and the way that our Windows servers are doing DNS inside this little network.
    My counterpart and I are going to be going through the DNS settings (BIND9 on ubuntu seems quite a bit different than BIND on FedoraCore 5, which was our last zimbra incarnation)....looking at problems on Friday.

    That is an interesting observation, though.
    I wonder: if IMAP gets clogged up and ties up network resources, -AND- now the MX dig takes more time than it should...that might cause some lookups to fail, and pop all those msgs into the deferred queue.

    Good eyes, bill. Things are fine now, after a restart, and no one;s touching IMAP. I'll try to let you know what we find on Friday.

    merci,
    rick

  8. #8
    Join Date
    Nov 2006
    Location
    Minneapolis, MN
    Posts
    101
    Rep Power
    9

    Default

    Maybe some of this helps.
    :\
    zimbra@smtp:/home/tuser$ zmcontrol -v
    Release 5.0.4_GA_2101.UBUNTU6 UBUNTU6 NETWORK edition
    -----
    zimbra@smtp:/home/tuser$

    zimbra@smtp:/home/tuser$ zmcontrol -v


    Release 5.0.4_GA_2101.UBUNTU6 UBUNTU6 NETWORK edition
    ----------
    zimbra@smtp:/home/tuser$ zmcontrol status
    Host smtp.creativelights.com
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running
    ----
    zimbra@smtp:/home/tuser$ host `hostname`
    smtp.creativelights.com has address 10.0.0.1
    zimbra@smtp:/home/tuser$
    ----
    tuser@smtp:~$ dig creativelights.com any

    ; <<>> DiG 9.3.2 <<>> creativelights.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59578
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;creativelights.com. IN ANY

    ;; ANSWER SECTION:
    creativelights.com. 604800 IN SOA smtp.creativelights.com. admin.creativelights.com. 40412 604800 86400 2419200 604800
    creativelights.com. 604800 IN NS 10.0.0.1.creativelights.com.
    creativelights.com. 604800 IN MX 10 smtp.creativelights.com.
    creativelights.com. 604800 IN A 10.0.0.1

    ;; ADDITIONAL SECTION:
    smtp.creativelights.com. 604800 IN A 10.0.0.1

    ;; Query time: 2 msec
    ;; SERVER: 10.0.0.1#53(10.0.0.1)
    ;; WHEN: Thu Apr 17 10:53:43 2008
    ;; MSG SIZE rcvd: 154

    tuser@smtp:~$ dig creativelights.com mx

    ; <<>> DiG 9.3.2 <<>> creativelights.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53699
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;creativelights.com. IN MX

    ;; ANSWER SECTION:
    creativelights.com. 604800 IN MX 10 smtp.creativelights.com.

    ;; AUTHORITY SECTION:
    creativelights.com. 604800 IN NS 10.0.0.1.creativelights.com.

    ;; ADDITIONAL SECTION:
    smtp.creativelights.com. 604800 IN A 10.0.0.1

    ;; Query time: 169 msec
    ;; SERVER: 10.0.0.1#53(10.0.0.1)
    ;; WHEN: Thu Apr 17 10:53:53 2008
    ;; MSG SIZE rcvd: 96

Similar Threads

  1. help with smtp auth
    By pheonix1t in forum Installation
    Replies: 1
    Last Post: 04-27-2009, 07:56 AM
  2. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 12:44 PM
  3. Replies: 16
    Last Post: 02-19-2008, 02:08 PM
  4. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  5. INVALID_PDU error on 4.5 GA
    By figuser in forum Installation
    Replies: 33
    Last Post: 06-15-2007, 01:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •