Results 1 to 6 of 6

Thread: [SOLVED] Last login times for users

  1. #1
    Join Date
    Jul 2007
    Posts
    13
    Rep Power
    8

    Default [SOLVED] Last login times for users

    Is there anyway I can find out the last login time for my users?

    I have about 1000 users on my system, and I don't believe that all of them are still active. I was wondering if there is a query I can run, or search of some type?

    Thank you,

  2. #2
    Join Date
    Oct 2007
    Location
    North East England
    Posts
    167
    Rep Power
    8

    Default

    The Admin Console contains a similar Advanced Search feature found in the web client, which allows you to find accounts with various "login time" attributes.

    Click Accounts.
    Click Advanced Search button.
    Click Advanced Attributes - select your last login time criterea from here.
    Click the Save button.

  3. #3
    Join Date
    Apr 2006
    Location
    Illinois
    Posts
    194
    Rep Power
    9

    Default

    Or, ssh in and run zmaccts as zimbra user.

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Don't forget about checking the value of your zimbraLastLogonTimestampFrequency which will technically affect how accurate your results are: http://www.zimbra.com/forums/adminis...n-console.html

    In the admin console search bar it can be as simple as (zimbraLastLogonTimestamp<=2008xxxxxxxxxxZ)

    Some quick predefined searches are also available in your 5.0.x admin console on the bottom left:


    Advanced search builder referenced by webman:

  5. #5
    Join Date
    Jul 2007
    Posts
    13
    Rep Power
    8

    Default

    Thanks for all the help, unfortunately I don't have the advanced attributes available in my web GUI (I'm running v4.5), but the zmaccts command gave me exactly what i was looking for. This gives me the information in a file that I can manipulate.

    Thanks

  6. #6
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

Similar Threads

  1. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  2. imapsync and scalix
    By deugenin in forum Migration
    Replies: 3
    Last Post: 02-11-2008, 08:45 PM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  4. Replies: 4
    Last Post: 12-13-2007, 10:18 AM
  5. problem while building perl
    By ravinder in forum Developers
    Replies: 7
    Last Post: 05-29-2006, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •