Results 1 to 4 of 4

Thread: Persona envelope wrong.

  1. #1
    Join Date
    Dec 2007
    Location
    U.S.A
    Posts
    17
    Rep Power
    7

    Default Persona envelope wrong.

    We are in the process of trying to make the shared mailboxes work for us.
    The setup:
    We need to catch all email conversations between a couple of sales folks and their leads. I setup a shared mailbox (ex sales@domain.com) and shared it out with both of them. I also created a Persona for sales@domain.com and made sure that when responding from this folder that is automatically used that Persona. I don't want Saleperson A (SPa) to miss any conversation had with customers and Salesperson B (SPb) or visa versa. A new mail comes in to the shared mailbox and SPa responds, this currently adds a sent message to SPa's sent box. SPb does not see that reply and sends another email to customer making sales look incompetent.
    The attempted fix:
    The attempted fix is this. We happen to use a relay server in out infrastructure which also uses Postfix. The plan was to add a sender_bcc map to our relay server. Simply stated any mail from sales@domain.com to the outside world gets that mail bcc'd to itself. The idea being in conversation view SPa and SPb would see all conversation between themselves and customers.
    The Problem;
    Personas don't actually send as sales@domain.com, they send as the sender SPa@domain.com. When the email gets to the destination server all the information is correct. From, Reply-to all indicate sales@domain.com, but it travels through the zimbra box and my relay box I see the actually user not the persona.

    Any ideas on how to fix this are greatly appreciated.
    BTW:
    Code:
    zmcontrol -v
    Release 5.0.3_GA_2101.UBUNTU6 UBUNTU6 NETWORK edition
    Erik Linstad

  2. #2
    Join Date
    Dec 2007
    Location
    U.S.A
    Posts
    17
    Rep Power
    7

    Default

    I can't believe no one has any thoughts
    Erik Linstad

  3. #3
    Join Date
    Dec 2007
    Location
    U.S.A
    Posts
    17
    Rep Power
    7

    Default

    One more plea to the community for any answers or thoughts
    Erik Linstad

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Did you share the sent folder as well?

    You're going to need to put on 5.0.5 because some things have been tweaked but pretending there's no persona's for a minute, create 4 accounts:
    Shared
    User1 -manager of shared's inbox & sent
    User2 -viewer of shared's inbox & sent
    Test1
    Test2
    -I assume you might be doing viewer on both so one salesperson doesn't remove anything but just for example purposes to show it works.

    Send message from user1 to test1 or user2 to test2 and both user1 & 2 can see it - best if you're using conversation view so it's shown when working in shared's inbox.

    Zimbra will show this as 'sending on behalf'

    The headers look like:
    From: shared@domain.com (so to test1 or test2's perspective it's shared sending the email)
    Sender: user1@domain.com (so yes test1 or test2 can technically view the mail headers and see which salesperson sent it - some mail clients may display this)
    To: test1@domain.com

    Notice that there's absolutely no persona's needed here if you're using the ZWC.

    I say upgrade to 5.0.5 (see you on 5.0.3) because there have been several fixes lately. http://www.zimbra.com/forums/announcements/17360-5-0-5-released.html

    This one is fixed for 5.0.6: Bug 26066 - send on behalf doesn't work when "always compose in new window" enabled
    -So might make sure they're not using detached windows right now.
    Last edited by mmorse; 05-01-2008 at 08:57 AM.

Similar Threads

  1. Wrong dates in Zimbra Webmail
    By voltcraft in forum Migration
    Replies: 11
    Last Post: 06-08-2009, 04:12 AM
  2. Outlook persona - sending fails
    By jkoyle in forum Zimbra Connector for Outlook
    Replies: 7
    Last Post: 08-06-2008, 10:26 AM
  3. InitNotebookRequest error: sent to wrong host
    By cstolley in forum Developers
    Replies: 0
    Last Post: 07-10-2007, 11:30 AM
  4. HSM Error - "operation sent to wrong host"
    By ewlooney in forum Administrators
    Replies: 2
    Last Post: 02-13-2007, 06:59 AM
  5. Wrong icons in GA Zimbra web client
    By iain in forum Users
    Replies: 2
    Last Post: 02-13-2006, 03:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •