Results 1 to 3 of 3

Thread: Filters Forwarding Messages with Attachments Over 1MB

Hybrid View

  1. #1
    Join Date
    Mar 2008
    Washington, DC
    Rep Power

    Default Filters Forwarding Messages with Attachments Over 1MB

    Hi guys/gals!

    I am running into an issue where certain messages ended up delivered multiple times to a user's mailbox.

    After much troubleshooting, we think we caught how this is happening. However I'm not sure if there is a problem in our deployment or if its a bug. I was hoping some of the folks here could try to duplicate this so we can figure this out.

    Steps to reproduce:

    a) Setup a filter that includes a rule to file a message into a folder and forward to another off-server location
    b) Send an email that includes an attachment over 1MB to the account so that it is processed by the filter.
    c) Check /opt/zimbra/log/mailbox.log for something like:

    2008-04-30 12:25:04,609 WARN  [LmtpServer-18949] [;mid=5;] filter - Redirect to failed.  Saving message to INBOX.  javax.mail.MessagingException: Exception reading response;
      nested exception is:
   Read timed out
    2008-04-30 12:25:04,611 INFO  [LmtpServer-18949] [;mid=5;] mailop - Adding Message: id=1037066, Message-ID=<>, parentId=1037018, folderId=2, folderName=Inbox.
    2008-04-30 12:25:04,623 INFO  [LmtpServer-18949] [] ProtocolHandler - Exception occurred while handling connection
    java.lang.NullPointerException        at
            at        at
            at com.zimbra.cs.mime.ParsedMessage.closeFile(         at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliverMessageToLocalMailboxes(
            at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver(
            at com.zimbra.cs.lmtpserver.LmtpHandler.processMessageData(
            at com.zimbra.cs.lmtpserver.TcpLmtpHandler.continueDATA(
            at com.zimbra.cs.lmtpserver.LmtpHandler.doDATA(
            at com.zimbra.cs.lmtpserver.LmtpHandler.processCommand(
            at com.zimbra.cs.lmtpserver.TcpLmtpHandler.processCommand(
            at com.zimbra.cs.tcpserver.ProtocolHandler.processConnection(
            at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$ Source)
    2008-04-30 12:25:04,624 INFO  [LmtpServer-18949] [] ProtocolHandler - Handler exiting normally
    d) Check the defered mail queue about a minute or two later to see if the message ends up defered.

    It will deliver a copy locally, then the defered copy will stay in the queue and keep delivering locally as it continues to try to deliver remotely.


  2. #2
    Join Date
    Apr 2008
    Rep Power


    You will also see a copy put back in your main Inbox with the attachments that show a corrupt value in the size column of the web interface, and any other IMAP client cannot read the Inbox folder until this message is deleted.


  3. #3
    Join Date
    Mar 2008
    Washington, DC
    Rep Power


    Has anyone tried this by any chance?

Similar Threads

  1. zmtrainsa does not see attachments
    By dvb in forum Administrators
    Replies: 3
    Last Post: 04-24-2012, 08:18 AM
  2. [SOLVED] Re-creating the spam training e-mail account
    By richard-hdd in forum Administrators
    Replies: 21
    Last Post: 03-20-2012, 07:34 AM
  3. Replies: 0
    Last Post: 01-29-2008, 09:49 PM
  4. Forwarding, and forwarding as Attachments
    By gfdos.sys in forum Users
    Replies: 4
    Last Post: 06-06-2007, 07:22 AM
  5. Spam assassain not traiing properly!
    By Mike T in forum Administrators
    Replies: 1
    Last Post: 10-09-2006, 01:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts