Results 1 to 5 of 5

Thread: Welcome to nginx!

  1. #1
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default Welcome to nginx!

    Yesterday a switch died on our network. I was in Chicago so the e-mail server had no network/internet connectivity till this morning. When I got the switch replaced and everything hooked back up e-mail wasn't working. Going to our e-mail server produced a web page with that single line centered at the top of the page: "Welcome to nginx!". I've tried restarting the server, performing "zmcontrol stop" then "zmcontrol start". I can't get to the Zimbra admin site, it just gives me an "unable to connect" message in the browser.

    I'm out of my element here on where to go next. I'm downloading FOSS 5.0.5 to perform an upgrade (which I've been meaning to do anyway) in the hopes that maybe it will magically fix everything but any suggestions on what to look for/try would be greatly appreciated!

    I'm currently on FOSS 5.0.4 Ubuntu. TIA.

  2. #2
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    You're running Zimbra-proxy, aren't you ?
    Do you really need it ?

    What is the result of a "zmcontrol status" ?

  3. #3
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default

    Zimbra-proxy is installed/running though I don't need it (just never looked into how to turn it off). When I execute "zmcontrol status" it reports that the "mailbox" is stopped (everything is running), even though when I perform the zmcontrol stop/start no errors are reported (it says "done" next to everything). Searching forums now for related issues but this may be a needle in the haystack for me so any further assistance on what to look for next would be appreciated. Thanks.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    If you have the proxy running then you can disable it with the following:

    Code:
    zmproxyctl stop
    zmprov ms server.domain.com -zimbraServiceEnabled imapproxy
    zmcontrol stop
    zmcontrol start
    You should also reset the ports with this (all on one line):

    Code:
    zmprov -l ms server.domain.com zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995 zimbraPop3ProxyBindPort 7110 zimbraPop3SSLProxyBindPort 7995 zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraImapProxyBindPort 7143 zimbraImapSSLProxyBindPort 7993
    Then stop/start zimbra or reboot the server and see what happens then.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default

    The upgrade to 5.0.5 seems to have resolved whatever the root issues were (not that I'm pretending to know what actually happened). I did follow your advice, phoenix, and turn off the imapproxy service since we don't need it. Thanks for everyone's help. Not sure why an extended disconnect from the network would freak the server out but I'm just glad it's resolved and my users are happy again!

Similar Threads

  1. memcached and nginx pop3/imap auth problem.
    By serivo in forum Administrators
    Replies: 3
    Last Post: 04-22-2008, 09:13 AM
  2. Replacing perdition with nginx
    By Klug in forum Administrators
    Replies: 4
    Last Post: 12-03-2007, 09:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •