Results 1 to 6 of 6

Thread: Relay MTA for external delivery

  1. #1
    Join Date
    May 2008
    Posts
    19
    Rep Power
    7

    Default Relay MTA for external delivery

    Guys, I have a very frustrating issue- I have the fqdn specified in this mta field and it's not actually using it.

    There are a bunch of emails sitting in my deferred queue that when flushing or requeueing do not go out to my smarthost. I have used the following to try to force it b/c it wasn't taking my entry in the GUI:

    sudo -u zimbra ./zmprov ms localhost zimbraMtaRelayHost server70.appriver.com:25

    that shows up in my GUI just fine, restart zimbra with zmcontrol stop/start, send myself a test message and when i receive it and look at the internet headers it doesn't show that it went through any smart host. The reason stuff is sitting in my deferred queue is because the mail servers are having an issue with my PTR record-- normally not a problem b/c i send through an external MTA.

    Very strange that in my audit.log I get this:
    .168.168.201;ua=ZimbraWebClient - FF2.0 (Linux);] security - cmd=ModifyServer; name=zimbra.mail.hssc.com; zimbraMtaRelayHost=;

    Why is the last parameter blank???

    I have checked zmmtaconfig.log and see stuff like this:

    Fri Jun 6 15:34:58 2008 Sleeping...Key lookup failed.
    Fri Jun 6 15:35:10 2008 Skipping Configuration for server zimbra.mail.hssc.com No data returned.

    Is there somewhere else I need to look to find out why it's not taking or what could be wrong? I try zmlocalconfig and don't see any reference to the external mta for relay.

    Please help,, thanks

  2. #2
    Join Date
    May 2008
    Posts
    19
    Rep Power
    7

    Default

    Something must be wrong in dns/ldap.. Am I on the right track with that thought? I'm seeing this in zimbra.log

    un 6 19:45:19 frontend slapd[31173]: conn=86 fd=14 closed (connection lost)
    Jun 6 19:45:19 frontend slapd[31173]: conn=87 fd=15 closed (connection lost)
    Jun 6 19:45:19 frontend zimbramon[31625]: 31625:info: zmmtaconfig: Skipping Configuration for server zimbra.mail.hssc.com No data returned.
    Jun 6 19:45:19 frontend zimbramon[31625]: 31625:info: zmmtaconfig: Sleeping...Key lookup failed.

  3. #3
    Join Date
    May 2008
    Posts
    19
    Rep Power
    7

    Default

    I installed ldap-utils and tried the following,, is this even syntactically correct as a test? (my mail server is zimbra.mail.hssc.com)

    # ldapsearch -x -D "cn=zimbra,cn=mail,dc=hssc,dc=com" -W
    Enter LDAP Password:
    ldap_bind: Can't contact LDAP server (-1)
    root@frontend:/home/chris#

  4. #4
    Join Date
    Oct 2008
    Location
    Thailand
    Posts
    65
    Rep Power
    6

    Default How to set multiple MTA for external mail?

    I have 2 external mail servers.
    And I try to set MTA for external mail in Admin UI.
    I can set one.

    How I set 2 MTA for external mail?

  5. #5
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    I don't think you can .. is this for resilience ?

  6. #6
    Join Date
    Sep 2007
    Location
    Sydney / Australia
    Posts
    10
    Rep Power
    8

    Default

    For those who try to use multiple smarthosts / outgoing SMTP servers, you can do the following:

    1. Setup a MX record for each of the smarthosts you'd like to use in your DNS zone file:

    smtp-out.domain.com. IN MX 10 smtp-out-01.domain.com.
    smtp-out.domain.com. IN MX 10 smtp-out-02.domain.com.

    2. Point your Relay MTA for External Delivery (smarthost) to:

    smtp-out.domain.com

    3. Restart Zimbra.

    And you're done.

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 08:57 AM
  2. Relay MTA for external delivery
    By endorphine44 in forum Administrators
    Replies: 16
    Last Post: 05-08-2009, 08:24 AM
  3. Relay MTA for External Delivery
    By GoneWestCoast in forum Administrators
    Replies: 8
    Last Post: 01-18-2008, 12:15 PM
  4. admin reports being sent to MTA relay
    By dhickey in forum Administrators
    Replies: 5
    Last Post: 09-14-2007, 12:03 PM
  5. Relay MTA
    By PNE in forum Administrators
    Replies: 9
    Last Post: 03-12-2007, 02:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •