Results 1 to 2 of 2

Thread: [SOLVED] how to unselect installed packgaes

  1. #1
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    10

    Default [SOLVED] how to unselect installed packgaes

    i have a multiserver installation with a master ldap server (NE Centos4 5.0.6)and a second server without ldap.
    The server without ldap (NE Centos5 5.0.4) is a store only server using master ldap.

    I decide to upgrade this store only from 5.0.4 to 5.0.6 and installing ldap to promote it to replica.
    When asked
    Code:
    Select the packages to install
    Install zimbra-ldap [Y]

    i answered Y as explained in
    http://www.zimbra.com/docs/ne/latest...r_install/LDAP Replication.6.1.html

    Upgrade stopped when reading my.cnf.
    Code:
    Sun Jun  8 08:50:48 2008 Stopping zimbra services
    Sun Jun  8 08:50:53 2008 Verifying /opt/zimbra/conf/my.cnf
    Sun Jun  8 08:50:54 2008 UPGRADE FAILED - exiting
    without any reason.

    I restarted installation but now, sadly, it is searching for an inesistent ldap installation:

    Code:
    Backing up the ldap database...failed.
    could not stat config file "/opt/zimbra/conf/slapd.conf": No such file or directory (2)
    slapcat: bad configuration file!
    I would restart installation without ldap, restoring previous setting but now i am unable to select during installation
    do not install ldap

    how can do that?

    tia
    -m
    Last edited by maumar; 06-08-2008 at 02:09 AM.

  2. #2
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    10

    Default

    Quote Originally Posted by maumar View Post
    how can do that?
    with
    Code:
    rpm -e zimbra-ldap-5.0.6_GA_2313.RHEL5-20080522094306
    i was able to reinstalling and i was queried if zimbra-ldap has to be installed;
    i used libexec/zmsetup.pl to understand how a packege i known to be already installed

    Code:
    sub isInstalled {
      my $pkg = shift;
    
      my $pkgQuery;
    
      my $good = 0;
      if ($platform eq "DEBIAN3.1" || $platform eq "UBUNTU6" || $platform eq "UBUNTU7" || $platform eq "UBUNTUUNKNOWN" || $platform eq "DEBIAN4.0" || $platform eq "DEBIAN4.0_64" || $p
        $pkgQuery = "dpkg -s $pkg";
      } elsif ($platform =~ /MACOSX/) {
        my @l = sort glob ("/Library/Receipts/${pkg}*");
        if ( $#l < 0 ) { return 0; }
        $pkgQuery = "test -d $l[$#l]";
      } elsif ($platform =~ /RPL/) {
        $pkgQuery = "conary q $pkg";
      } else {
        $pkgQuery = "rpm -q $pkg";
      }

Similar Threads

  1. [SOLVED] Server statistics does not working
    By boblin in forum Administrators
    Replies: 46
    Last Post: 11-20-2008, 04:15 AM
  2. Moving zimbra from Ubuntu 6.06 to same
    By tseinc in forum Installation
    Replies: 3
    Last Post: 06-10-2008, 10:45 AM
  3. speed up the net
    By mcesari in forum Administrators
    Replies: 10
    Last Post: 04-25-2008, 11:24 AM
  4. Debian - Upgrade from 4.5.6
    By magikman in forum Installation
    Replies: 1
    Last Post: 01-19-2008, 11:59 AM
  5. Problems when making and installing Perl
    By wildhuman in forum Developers
    Replies: 10
    Last Post: 09-08-2006, 05:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •