Results 1 to 10 of 10

Thread: [SOLVED] How to raise/increase the max file attachments? Error with zimbraMtaMaxMessa

  1. #1
    Join Date
    Apr 2008
    Posts
    69
    Rep Power
    7

    Question [SOLVED] How to raise/increase the max file attachments? Error with zimbraMtaMaxMessa

    Hello.

    First, I like to say that Zimbra is just awesome. Finally, beauty + features + open source all rolled up into one.

    I've got ZCS 5.0.6 64-bit on CentOS 5.1 running wonderfully.

    I need to be able to finish migrating messages from the old server to ZCS, but some of the attachments from emails in the older server are huge.

    I need to raise ZCS's max sizes to 50MB to 100MB (yes, that big but for just a few emails, I was young and stupid back then. Now I'm just old ), but I'm getting a "zimbraMtaMaxMessageSize must be a valid integer:" error:

    Code:
    [zimbra@power ~]$ zmprov mcf zimbraFileUploadMaxSize 50000000000
    [zimbra@power ~]$ 
    [zimbra@power ~]$ zmprov mcf zimbraMtaMaxMessageSize 50000000000
    ERROR: account.INVALID_ATTR_VALUE (zimbraMtaMaxMessageSize must be a valid integer: 50000000000)
    [zimbra@power ~]$ zmprov mcf zimbraMtaMaxMessageSize 5000000000
    ERROR: account.INVALID_ATTR_VALUE (zimbraMtaMaxMessageSize must be a valid integer: 5000000000)
    [zimbra@power ~]$
    I also tried it in the admin GUI ("Global Settings" --> "MTA" --> "Maximum message size (kb):" ), but got the same error.

    I've found bugzilla #26840, but it shows it's resolved in 5.0.5:
    Bug 26840 – Wrong error while trying to set the mta max size

    What are valid integers for 50MB or 100MB? or even higher?

    Thank you!

  2. #2
    Join Date
    Apr 2007
    Location
    Los Gatos, CA
    Posts
    138
    Rep Power
    8

    Default

    838860800 bits = 100 MB

    zmprov gacf | grep zimbraMtaMaxMessageSize
    zmprov gacf | grep zimbraFileUploadMaxSize
    --> to check the size of each

    zmprov mcf zimbraMtaMaxMessageSize 838860800
    zmprov mcf zimbraFileUploadMaxSize 838860800
    --> to make each one 100 MB

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by frankman View Post
    What are valid integers for 50MB or 100MB? or even higher?
    What you've done in your settings is give the maximum size of 5GB, that's what invalid about it. It's outside the allowed range for that variable, it's a 32 bit signed integer and has a maximum size of 2GB.

    BTW the bugzilla entry you referenced wasn't 'fixed', it was invalid and therefore closed.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    Apr 2007
    Location
    Los Gatos, CA
    Posts
    138
    Rep Power
    8

    Default

    5.820766091347 GB, to be exact. Sorry... too much coffee.

  5. #5
    Join Date
    Apr 2008
    Posts
    69
    Rep Power
    7

    Thumbs up

    Thanks, Daniel! That worked:

    Code:
    [zimbra@power ~]$ zmprov mcf zimbraMtaMaxMessageSize 838860800
    [zimbra@power ~]$ zmprov gacf | grep zimbraMtaMaxMessageSize
    zimbraMtaMaxMessageSize: 838860800
    [zimbra@power ~]$ zmprov gacf | grep zimbraFileUploadMaxSize
    zimbraFileUploadMaxSize: 50000000000
    [zimbra@power ~]$ zmprov mcf zimbraFileUploadMaxSize 838860800
    [zimbra@power ~]$ zmprov gacf | grep zimbraFileUploadMaxSize
    zimbraFileUploadMaxSize: 838860800
    [zimbra@power ~]$
    And thanks, phoenix for the extra info. I didn't know the number was in bits!

    (It'd be nice to have add that info to the error message that the number is in bits, rather than bytes or other. I got used to other programs and installers to type in a whole number (ie. 5000000 for 5 megabytes, etc.) or "K", "M" or "G" after the number (ie. 5M, 10G, etc.) and the program would do the conversion for me. )

    I'll mark this as solved.

  6. #6
    Join Date
    Nov 2008
    Location
    Denver, CO
    Posts
    221
    Rep Power
    6

    Default

    Quote Originally Posted by danielfarrelly View Post
    838860800 bits = 100 MB

    zmprov gacf | grep zimbraMtaMaxMessageSize
    zmprov gacf | grep zimbraFileUploadMaxSize
    --> to check the size of each

    zmprov mcf zimbraMtaMaxMessageSize 838860800
    zmprov mcf zimbraFileUploadMaxSize 838860800
    --> to make each one 100 MB
    This is incorrect, I think. Max message size (and File upload max size) are expressed in bytes, not bits. A 100MB setting would be 100x1024x1024
    104857600. Your example is actually 800MB.

  7. #7
    Join Date
    Apr 2007
    Location
    Los Gatos, CA
    Posts
    138
    Rep Power
    8

    Default

    Quote Originally Posted by LaFong View Post
    This is incorrect, I think. Max message size (and File upload max size) are expressed in bytes, not bits. A 100MB setting would be 100x1024x1024
    104857600. Your example is actually 800MB.
    Maximum message size is measured in kb (see Global Settings).
    100 MB = 819200 kb
    100 MB = 104857600 bytes
    100 MB = 838860800 bits

    Consequently...
    100 MB = 800 Mb, not MB

  8. #8
    Join Date
    Nov 2008
    Location
    Denver, CO
    Posts
    221
    Rep Power
    6

    Default

    Your math is right, but the web page isn't. I think the Global Settings page is wrong. It is not kb.

    Global settings shows 50000kb:
    [root@mail bin]# ./zmprov gcf zimbraMtaMaxMessageSize
    zimbraMtaMaxMessageSize: 51200000

    [root@mail bin]# grep message_size_limit /opt/zimbra/postfix/conf/main.cf
    message_size_limit = 51200000

    Global settings shows 100000kb:
    [root@mail bin]# ./zmprov gcf zimbraMtaMaxMessageSize
    zimbraMtaMaxMessageSize: 102400000

    [root@mail bin]# grep message_size_limit /opt/zimbra/postfix/conf/main.cf
    message_size_limit = 102400000

    From postfix.org site:
    message_size_limit (default: 10240000)
    The maximal size in bytes of a message, including envelope information.
    From Zimbra site:
    Configuring maxmessagesize - Zimbra :: Wiki

    And, zimbraFileUploadMaxSize is no longer used for mail:
    "Until ZCS 5, there is a separate configuration parameter for file uploads."

    Of course, the General Information tab of General Settings still shows it, but its use has changed:
    Bug 27610 – Use zimbraMtaMaxMessageSize exclusively for mail, and use zimbraFileUploadMaxSize for docs/briefcase
    Turns out, it now only applies to Docs/Briefcase, not mail messages:
    "Add zimbraFileUploadMaxSize to GlobalConfig -> General since it is not applied to MTA but docs/briefcase"

    I tried to check whether the docs/briefcase max (apparently in SOAP) was set in kb, but didn't have any luck. After many years, and hundreds of applications, I do not recall a single one which set sizes in kb.
    Last edited by LaFong; 12-05-2008 at 05:50 PM.

  9. #9
    Join Date
    Oct 2008
    Location
    Thailand
    Posts
    65
    Rep Power
    6

    Default How I can set max size for each user

    I want to use zimbraMtaMaxMessageSize for set maximum size for each user.
    I try to use this command
    # zmprov ma user@domain.com +zimbraMtaMaxMessageSize 1024000
    but I got error like this
    ERROR: service.INVALID_REQUEST (invalid request: LDAP schema violation: [LDA rror code 65 - attribute 'zimbraMtaMaxMessageSize' not allowed])

    How can I do for solve this problem.
    ***If zimbra can not do this feature please let me know.

    thank you for reply.
    Last edited by ohm_g7; 02-22-2009 at 10:54 PM.

  10. #10
    Join Date
    Nov 2008
    Location
    Denver, CO
    Posts
    221
    Rep Power
    6

    Default

    I think zimbraMtaMaxMessageSize creates a Postfix global setting, and cannot be set per user.

Similar Threads

  1. speed up the net
    By mcesari in forum Administrators
    Replies: 10
    Last Post: 04-25-2008, 11:24 AM
  2. centos 5 zimbra 4.5.6 no statistics
    By rutman286 in forum Installation
    Replies: 9
    Last Post: 08-14-2007, 09:30 AM
  3. Opensource backup Question.
    By nfear24 in forum Administrators
    Replies: 3
    Last Post: 03-31-2007, 11:47 PM
  4. Traslation SVN tree status
    By meikka in forum I18N/L10N - Translations
    Replies: 7
    Last Post: 02-13-2007, 10:13 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •