Results 1 to 3 of 3

Thread: Domain Change/Account Restore + Posix / Samba Issues

  1. #1
    Join Date
    Oct 2007
    Posts
    9
    Rep Power
    8

    Default Domain Change/Account Restore + Posix / Samba Issues

    Hi,

    Is there a good way to rename your domain and pull the posix/samba data along with the rename. IE:

    zmprov -l renameDomain xyz.com abc.com - is working just fine for moving the zimbra data, however all of the posix/samba data doesn't move, which causes low level single sign on services that rely on the posix data to break.


    Another issue when trying to recover an account that has been deleted, which contained posix/samba data. The restore fails because the posix/samba data is either not getting backed up or the posix/samba plugin doesnt have a procedure to be called in conjunction with the restore.

    These issues are going to be a potential headache in the future! How can they be resolved!

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Quote Originally Posted by tmf View Post
    Is there a good way to rename your domain and pull the posix/samba data along with the rename. IE:

    zmprov -l renameDomain xyz.com abc.com - is working just fine for moving the zimbra data, however all of the posix/samba data doesn't move, which causes low level single sign on services that rely on the posix data to break.
    hm

    Quote Originally Posted by tmf View Post
    Another issue when trying to recover an account that has been deleted, which contained posix/samba data. The restore fails because the posix/samba data is either not getting backed up or the posix/samba plugin doesnt have a procedure to be called in conjunction with the restore.
    Vote for / support ticket tag / cc watch: Bug 20363 - BNR fails to restore accounts that were created and backed up prior to Zimbra-Samba integration

  3. #3
    Join Date
    Oct 2007
    Posts
    9
    Rep Power
    8

    Default

    I'll vote for that - also maybe rename domain is also related to restore in some ways as well..... here is a more complete example of what is going on...

    INITIAL STAGE

    LDAP View
    dc=xyz, dc=com
    ou=groups
    ou=machines
    ou=people
    sambaDomainName=XYZ.COM

    authconfig - general settings ( used to set up a single sign on service)
    LDAP Url: ldap://ldap1.xyz.com/
    Base DN: dc=xyz, dc=com

    execute: getent passwd
    display all users in zimbra ldap system

    ------------------------------------
    now execute domainRename on zmprov xyz.com -> abc.com
    ------------------------------------

    LDAP View
    dc=xyz, dc=com
    ou=groups
    ou=machines
    sambaDomainName=XYZ.COM

    dc=abc, dc=com
    ou=people

    authconfig - general settings ( used to set up a single sign on service)
    LDAP Url: ldap://ldap1.abc.com/
    Base DN: dc=abc, dc=com

    execute: getent passwd
    display no users from the zimbra system

    ------------------------------------
    now execute domainRename on zmprov abc.com -> xyz.com
    ------------------------------------
    It returns to the INITIAL STAGE as it should with nothing broken

Similar Threads

  1. Replies: 7
    Last Post: 04-27-2009, 03:49 AM
  2. Replies: 20
    Last Post: 03-18-2008, 06:37 AM
  3. [SOLVED] Remove main domain!
    By zibra in forum Administrators
    Replies: 11
    Last Post: 09-27-2007, 09:50 AM
  4. Samba Posix account configuration problem
    By audi in forum Administrators
    Replies: 4
    Last Post: 08-16-2007, 01:22 AM
  5. A couple of install issues -- MX and domain
    By Storm16 in forum Installation
    Replies: 2
    Last Post: 10-31-2006, 11:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •