Results 1 to 6 of 6

Thread: Right royal mess - Hostname change

  1. #1
    Join Date
    Oct 2006
    Posts
    26
    Rep Power
    9

    Default Right royal mess - Hostname change

    Well I might have made a right royal mess of my Zimbra install.

    Need to change the hostname as at the moment the EHLO does not match the external IP lookup. Some emails are getting black holed. Doh

    Anyway using the zmlocalconfig -e command I changed all references to the new hostname. Ensured the new name resolved internally and restarted. First issues was with ldap not able to connect.

    I then proceeded to try and edit the ldap server settings however can't seem to get my password accepted with Ldap Browser and using "uid=zimbra,cn=admins,cn=zimbra" for the username. Even attempted to issue a zmldappasswd command to reset the password.

    Whats the best way forward. I think I need to logon to the ldap server to make some more config changes however can't logon using the ldap browser. Please help

  2. #2
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    Ouch, not a fun time!
    Can we take a quick step back a second, is this NE or OSS and what happened to start this problem in the first place? In other words, can you restore to a backup to get everything up and running while you evaluate the next steps?

  3. #3
    Join Date
    Oct 2006
    Posts
    26
    Rep Power
    9

    Default Okay

    It is OSS edition

    I have been able to get it working again by reversing the changes I made.

    Only impact is the Admin shows two servers. One as the external domain the the other as the internal.

    All I want is so when I send an email the EHLO command uses my external FQDN and not my internal.

    Thanks

    Paul

  4. #4
    Join Date
    Mar 2007
    Location
    Austin
    Posts
    441
    Rep Power
    8

    Default

    If you're changing the hostname, have you looked at ZmSetServerName - Zimbra :: Wiki ?

    I followed that, and only had a few small things left to fix/change. Mostly old logger information that got fixed when I redid the logger DB. You may want to delete the new sorta-invalid server you created first.

  5. #5
    Join Date
    Oct 2006
    Posts
    26
    Rep Power
    9

    Default

    How do I go around about deleting that stray entry?

  6. #6
    Join Date
    Jul 2006
    Posts
    23
    Rep Power
    9

    Default

    If you just need to change the hostname used at HELO, all you need to do is this:

    zmprov mcf zimbraMtaMyHostname host.name

    And restart postfix.

    There's a thread here too:

    http://www.zimbra.com/forums/install...html#post90561

    --Chris

Similar Threads

  1. Zimbra Server very slow - Too many SMTP connections
    By pc-nico in forum Administrators
    Replies: 23
    Last Post: 06-05-2008, 05:12 AM
  2. Replies: 4
    Last Post: 03-24-2008, 12:12 AM
  3. Change hostname
    By bramm in forum Administrators
    Replies: 1
    Last Post: 07-31-2007, 11:30 PM
  4. Change hostname and IP Address!
    By celeron in forum Administrators
    Replies: 6
    Last Post: 07-15-2007, 09:27 PM
  5. Installation Cancelled - Zimbra-spell !
    By Ledg in forum Installation
    Replies: 4
    Last Post: 10-19-2006, 02:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •