Results 1 to 2 of 2

Thread: [SOLVED] Problem with postfix and generic maps, please help

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Rep Power

    Default [SOLVED] Problem with postfix and generic maps, please help

    Hi, I am new to zimbra so please forgive any stupid questions. I have a problem here with my setup and I hope you can help me.

    I have set up zcs-5.0.6_GA_2313 on my home network with centos 4 and dyndns. My mail is being hosted at a public provider and then forwarded to the dyndns address. Outgoing mail is being sent through the provider's smarthost. So far so good...

    Now when I want to send mails from zimbra, I want the recipient to see my public mail address (say instead of the local address (say @lan.local). To do this, I have set up smtp_generic_maps = hash:/opt/zimbra/postfix/conf/generic in which works fine - for outgoing mail.

    Here comes the problem: on incoming mail, address mapping is also being performed, translating the local address @lan.local back into, which causes the mail to be re-sent to the provider and not reaching the mailbox.

    I have meddled with receive_override_options in and but no luck.

    Your help is very much appreciated!
    Last edited by splatterpop; 06-22-2008 at 07:08 AM.

  2. #2
    Join Date
    Jun 2008
    Rep Power


    Hi again, i figured out a workaround to my problem. Perhaps this might be of interest to others, so I am posting it here.

    The problem was related to content filtering (content_filter = smtp-amavis:[]:10024 in Because amavis itself works as a smtp server, it is also affected by the config changes and started to do generic address mapping and to direct mails away from the local mail server.

    So the obvious workaround was to turn off content filtering, and everything worked. Except virus scanning that is. I havent found a way to tell amavis not to do address mapping.

Similar Threads

  1. Sending Mail! Still something wrong!
    By BlueHaven in forum Installation
    Replies: 11
    Last Post: 08-02-2007, 04:19 PM
  2. Cannot send mail.
    By jeremyshoe in forum Installation
    Replies: 7
    Last Post: 10-17-2006, 09:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts