In my attempt to get LDAP replication working I have stumbled upon a problem. I was trying to do a zmupdateauthkeys but the command couldn't find any keys for any of my servers. So I decided to run zmsshkeygen, it starts out fine, by then it chokes when it tries to put the key into the LDAP tree. It states the attribute must only be 1024 in length, but the length of the zimbra_identity.pub file is 1120.
Code:
Generating public/private dsa key pair.
Your identification has been saved in /opt/zimbra/.ssh/zimbra_identity.
Your public key has been saved in /opt/zimbra/.ssh/zimbra_identity.pub.
The key fingerprint is:
xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx jumbo.xxxxx.on.ca
ERROR: account.INVALID_ATTR_VALUE (zimbrasshpublickey value length(1120) larger then max allowed: 1024)
I have tried to go through the process manually, and I still got stuck in the same spot, I even tried to put just the key into the LDAP tree, meaning excluding the ssh-dss at the beginning of the file and the hostname at the end.

I'd really appreciate some help on this, if there is anything I can do or help in any way please let me know, because this is a big problem for me as I can't move forward without this.