Results 1 to 2 of 2

Thread: [SOLVED] UnsatisfiedLinkError when restoring from backups

  1. #1
    Join Date
    Mar 2006
    Posts
    16
    Rep Power
    9

    Default [SOLVED] UnsatisfiedLinkError when restoring from backups

    I am restoring a system installed on x86 Ubuntu onto a x86_64 RHEL 5.0 box. All goes well until I run 'zmrestoreoffline -sys -a all -c -b' and get the following exception:

    Code:
    Fatal error: terminating: Failed to loadLibrary(zimbra-native)
    java.lang.UnsatisfiedLinkError: no zimbra-native in java.library.path
            at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1682)
            at java.lang.Runtime.loadLibrary0(Runtime.java:823)
            at java.lang.System.loadLibrary(System.java:1030)
            at com.zimbra.znative.Util.loadLibrary(Util.java:48)
            at com.zimbra.znative.Util.<clinit>(Util.java:64)
            at com.zimbra.znative.IO.<clinit>(IO.java:58)
            at com.zimbra.cs.store.FileBlobStore.link(FileBlobStore.java:233)
            at com.zimbra.cs.mailbox.Mailbox.addMessageInternal(Mailbox.java:4617)
            at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.java:4330)
            at com.zimbra.cs.redolog.op.CreateMessage.redo(CreateMessage.java:432)
            at com.zimbra.cs.redolog.RedoPlayer.playOp(RedoPlayer.java:314)
            at com.zimbra.cs.redolog.RedoPlayer.scanLog(RedoPlayer.java:131)
            at com.zimbra.cs.backup.RestoreAccountSession.playBackRedoOps(RestoreAccountSession.java:318)
            at com.zimbra.cs.backup.RestoreAccountSession.endRestore(RestoreAccountSession.java:248)
            at com.zimbra.cs.backup.FileBackupTarget$RestoreAcctSession.endRestore(FileBackupTarget.java:2011)
            at com.zimbra.cs.backup.FileBackupTarget.restore(FileBackupTarget.java:420)
            at com.zimbra.cs.backup.BackupManager.restore(BackupManager.java:716)
            at com.zimbra.cs.backup.BackupManager.restore(BackupManager.java:656)
            at com.zimbra.cs.backup.RestoreOfflineUtil.restore(RestoreOfflineUtil.java:154)
            at com.zimbra.cs.backup.RestoreOfflineUtil.main(RestoreOfflineUtil.java:52)
    I fixed this by adding '-Djava.library.path=/opt/zimbra/lib' to the java invocation in '/opt/zimbra/bin/zmrestoreoffline'.

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    This was fixed in ZCS 5.0.6: Bug 27617 - Zmrestoreoffline: exception raised on accounts with share messages
    Quote Originally Posted by solarsail View Post
    I fixed this by adding '-Djava.library.path=/opt/zimbra/lib' to the java invocation in '/opt/zimbra/bin/zmrestoreoffline'.
    To zmrestoreoffline
    under this line:
    -Xms${jm}m -Xmx${jm}m ${mailboxd_java_options}
    add the following lines:
    -Dzimbra.home=${zimbra_home} \
    -Djava.library.path=${zimbra_home}/lib \
    Last edited by mmorse; 06-30-2008 at 03:45 PM.

Similar Threads

  1. Restoring mails, folders and calendars
    By iain in forum Administrators
    Replies: 3
    Last Post: 03-17-2008, 11:14 AM
  2. Restoring backups to future versions
    By dannylandulf in forum Installation
    Replies: 1
    Last Post: 02-08-2008, 06:33 PM
  3. Question about NE and Backups.
    By dougconley in forum Administrators
    Replies: 2
    Last Post: 12-18-2007, 12:56 AM
  4. Network Edition backups out of control
    By dameron in forum Administrators
    Replies: 1
    Last Post: 08-29-2007, 03:38 PM
  5. Problem when restoring from incremental backup
    By Eyfi in forum Administrators
    Replies: 4
    Last Post: 06-28-2007, 09:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •