Results 1 to 10 of 103

Thread: Zimbra Integration With Samba - Ubuntu Based

Threaded View

  1. #11
    Join Date
    Sep 2010
    Posts
    113
    Rep Power
    5

    Default not yet for me

    Quote Originally Posted by maxxer View Post
    I did a deployment last week, and worked perfectly, just like 6 do!
    Nice to hear that..I followed the howtoforge article and used the wiki article where needed:
    in section 9 - More Zimbra Configuration, since the configuration changed (no slapd.conf.in file any more) I used the wiki article about adding ldap schemas.
    And I installed the two users using posixusers.ldif.

    "Then after the samba configuration I should see the samba domain."
    This is where I am stuck, I don't see my domain.

    I am using a split dns setup and the dig and hostname commands are not showing unusual answers (I attached the log).

    samba conf file:
    Code:
    [global]
    	workgroup = HEEM
    	netbios name = SAMBA
    	server string = %h server (Samba, Ubuntu)
    	passdb backend = ldapsam:ldap://mail.heem.local/
    	passwd program = /usr/bin/passwd %u
    	passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
    	log level = 3
    	syslog = 0
    	log file = /var/log/samba/log.%m
    	max log size = 1000
    	name resolve order = wins bcast hosts
    	add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u
    	add machine script = /usr/sbin/adduser --shell /bin/false --disabled-password --quiet --gecos "machine account" --force-badname %u
    	logon script = logon.cmd
    	logon path = 
    	logon home = 
    	domain logons = Yes
    	os level = 33
    	preferred master = Yes
    	domain master = Yes
    	dns proxy = No
    	wins support = Yes
    	ldap admin dn = "cn=config"
    	ldap group suffix = ou=groups
    	ldap machine suffix = ou=machines
    	ldap passwd sync = yes
    	ldap suffix = dc=heem,dc=local
    	ldap user suffix = ou=people
    	panic action = /usr/share/samba/panic-action %d
    
    [homes]
    	comment = Home Directories
    	valid users = %S
    	read only = No
    
    [netlogon]
    	comment = Network Logon Service
    	path = /var/lib/samba/netlogon
    	guest ok = Yes
    	locking = No
    
    [profiles]
    	comment = Users profiles
    	path = /var/lib/samba/profiles
    	read only = No
    
    [profdata]
    	comment = Profile Data Share
    	path = /var/lib/samba/profdata
    	read only = No
    	profile acls = Yes
    
    [printers]
    	comment = All Printers
    	path = /tmp
    	create mask = 0700
    	printable = Yes
    	browseable = No
    	browsable = No
    
    [print$]
    	comment = Printer Drivers
    	path = /var/lib/samba/printers
    Here are the zimlets' xml files:
    Code:
    <zimletConfig name="zimbra_samba" version="6"> 
       <global> 
                   <property name="gidBase">10000</property> 
                   <property name="uidBase">10000</property> 
                   <property name="ridBase">10000</property> 
                   <property name="ldapSuffix">dc=heem,dc=local</property> 
                   <property name="ldapGroupSuffix">ou=groups</property> 
                   <property name="ldapMachineSuffix">ou=machines</property> 
       </global> 
    </zimletConfig>
    Code:
    <zimletConfig name="zimbra_posixaccount" version="6.0.2">
        <global>
           	<property name="loginShells">/bin/bash,/bin/sh,/bin/false</property>        
        	<property name="homePath">/home/%u</property>        
       		<property name="gidBase">10000</property>        
       		<property name="uidBase">10000</property>   
    		<property name="ldapSuffix">dc=heem,dc=local</property>
    		<property name="ldapGroupSuffix">ou=groups</property>
        </global>
    </zimletConfig>
    Quote Originally Posted by maxxer View Post
    No particular issues, except the zimlets icon not showing up in admin interface.
    A logout/login from the admin console has always worked for me, the zimlets seem to need that refresh .
    Attached Files Attached Files
    Last edited by rosch; 03-11-2011 at 03:30 AM. Reason: nicer formatting and added xml files
    --
    cheers

Similar Threads

  1. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 01:00 AM
  2. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 08:56 PM
  3. Replies: 22
    Last Post: 12-02-2007, 04:05 PM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  5. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 09:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •