Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [SOLVED] salocal.cf problem

  1. #1
    Join Date
    Dec 2007
    Location
    Fresno, CA
    Posts
    7
    Rep Power
    7

    Default [SOLVED] salocal.cf problem

    I'm attempting to adjust some SpamAssassin scores and am having problems getting my changes to take affect. I've added the following to the salocal.cf file:

    #
    # set higher score for URIBL_SBL checks
    #
    score URIBL_AB_SURBL 3
    score URIBL_JP_SURBL 3
    score URIBL_OB_SURBL 3
    score URIBL_PH_SURBL 3
    score URIBL_RHS_DOB 3
    score URIBL_SBL 5.5
    score URIBL_SC_SURBL 3
    score URIBL_WS_SURBL 3
    score URIBL_BLACK 4

    #
    # set bayes scores higher
    #
    score BAYES_50 1.001
    score BAYES_60 2
    score BAYES_80 3
    score BAYES_90 3.5
    score BAYES_95 4
    score BAYES_99 4.5

    #
    # other general score increases
    #
    score DCC_CHECK 4.0
    score SPF_FAIL 4.5


    After restarting Zimbra the scores don't change in the email headers. The default scores from 50_scores.cf are still used. The local config is set correctly in Amavisd.cf and points toward /opt/zimbra/conf/salocal.cf.

    Any ideas what might be going on?

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Code:
    su - zimbra
    zmcontrol -v
    http://www.zimbra.com/forums/announc...r-profile.html please

  3. #3
    Join Date
    Dec 2007
    Location
    Fresno, CA
    Posts
    7
    Rep Power
    7

    Default

    I've now updated my profile. Any thoughts about the problem I posted?

  4. #4
    Join Date
    Dec 2007
    Location
    Fresno, CA
    Posts
    7
    Rep Power
    7

    Default Solved???

    OK - I put those score changes into the local.cf file at /opt/zimbra/conf/spamassassin/local.cf and now the score increases are being honored. So /opt/zimbra/conf/salocal.cf is not observed at launch time, even though the documentation indicates otherwise.

  5. #5
    Join Date
    May 2007
    Posts
    17
    Rep Power
    8

    Default

    same for me, only

    /opt/zimbra/conf/spamassassin/local.cf

    works for change conf.

  6. #6
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    you'll want to change /opt/zimbra/conf/salocal.cf.in we also found a bug that is fixed in 5.0.10 that had the loading order of /opt/zimbra/conf/spamassassin before /opt/zimbra/conf/salocal.cf which prevented config overrides.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  7. #7
    Join Date
    Jun 2008
    Posts
    45
    Rep Power
    7

    Default

    I can't seem to get a language filter to work in my salocal.cf I've tried to use /opt/zimbra/conf/salocal.cf and /opt/zimbra/conf/spamassassin/local.cf for the first file, when I restart zimbra, the settings are lost, and in the local.cf using ok_languages en fr
    ok_locales en
    does nothing to stop other languages and cryllic messages coming in. I've read through ALL the spam stuff around and don't see much about stoping this from coming in. Any help would be greatly appreciated!
    OS : Ubuntu 6.02 LTS
    ZCS : zcs-NETWORK-6.0.8_GA_2661.UBUNTU6

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Did you read the post imemediately above yours and see which salocal file you're supposed to modify?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Dec 2007
    Posts
    2
    Rep Power
    7

    Default

    Hello,

    I'm in 5.0.10 Ubuntu 8.04.1LTS 64bits and I made the brian changes, but only in the local.cf that this is ok.

    Thank you.

  10. #10
    Join Date
    Jun 2008
    Posts
    45
    Rep Power
    7

    Default

    Quote Originally Posted by phoenix View Post
    Did you read the post imemediately above yours and see which salocal file you're supposed to modify?
    forgot the salocal.cd.in I'll test this somemore with the language filtering

    Thanks!

    OS : Ubuntu 6.02 LTS
    ZCS : zcs-NETWORK-6.0.8_GA_2661.UBUNTU6

Similar Threads

  1. Missing Email Problem
    By prox in forum Zimbra Connector for Outlook
    Replies: 6
    Last Post: 03-16-2008, 10:01 PM
  2. WindowsMobile - problem with regional fonts
    By wojo2000 in forum Zimbra Mobile
    Replies: 0
    Last Post: 06-22-2007, 10:37 AM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •