Results 1 to 5 of 5

Thread: port 25 connection fails

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Posts
    5
    Rep Power
    9

    Default port 25 connection fails

    I have a box on DSL, that is behind a NAT, mail server has a private ip address, I'm forwarding all the required ports

    192.168.100.10

    I have a example.com and a DNS entry of mail.example.com that points to a real IP address
    64.190.20.20 (made up to protect the innocent) that is the public dsl address.

    my /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    192.168.100.10 mail.example.com mail

    First ? should that entry be nat's private address as it is, or should it be the public ip of my DSL.

    Ok so here is my first problem.

    I can "telnet localhost 25" and conect to the mail server, but when I "telnet 192.168.100.10 25" I get connection refused. I have iptables off for testing. And I can get web part of zimbra so I can connect to 192.168.100.10 to connect to other services just fine.

    So what have I done wrong.

    FYI, this is only temorary till I move the box to the datacenter. But I'd like to get it working and test zimbra before I move it.

  2. #2
    Join Date
    Feb 2006
    Posts
    5
    Rep Power
    9

    Default

    found the problem, sendmail was running too, once I turned that off it work, but still any info on the nat setup would be appreciated

  3. #3
    Join Date
    Feb 2006
    Posts
    5
    Rep Power
    9

    Default

    ok so I can telnet to the ports but I can recieve or send. I believe my ISP is blocking outgoing smtp, as I can't telnet to anyones port 25.

    when I recieve mail I see it hit my logs, but I never get it. I think cause it trys to send to to the domain name and that is the public IP address

  4. #4
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    11

    Default

    what exactly do you see in /var/log/zimbra.log?

    do you have dns lookups enabled? if so you'll have to run dns locally (or disable it).

    if the isp is blocking outbound 25, they should have their smtp mta available, which you can enter in zimbra as the relay host.

  5. #5
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    search the forums - it's probably the fastest way to find out that you've got a log in /var/log/zimbra.log that looks like:
    .* postfix/lmtp .* connection refused

    and the solution is to split DNS or to forward port 7025

Similar Threads

  1. Replies: 3
    Last Post: 07-19-2007, 03:00 AM
  2. Error on openSUSE 10.1
    By piti in forum Installation
    Replies: 7
    Last Post: 11-07-2006, 01:21 PM
  3. ldap 389: port connection refused
    By koby in forum Installation
    Replies: 4
    Last Post: 09-07-2006, 02:03 AM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  5. Connection refused (port 10024)
    By jholder in forum Users
    Replies: 6
    Last Post: 12-13-2005, 12:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •