Results 1 to 3 of 3

Thread: error 49 after enabling replica

  1. #1
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    8

    Default error 49 after enabling replica

    after correctly issued:
    zmlocalconfig -e ldap_url=”ldap://<replicahost> ldap://<masterhost>”

    as in http://www.zimbra.com/docs/ne/latest...r_install/LDAP Replication.6.1.html

    i get this into zimbra.log

    dict_ldap_connect: Unable to bind to server ldap://replica.xxx.it:389 ldap://master.xxx.it:389 as uid=zmpostfix,cn=appaccts,cn=zimbra: 49 (Invalid credentials)

    any advice would be apreciated

    m

  2. #2
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    8

    Arrow

    i have 3 server
    master ldap -> mailz
    store only -> store
    replica -> mbox


    at this moment the store server is using ldap://mailz.xxx.it:389 as ldap server\
    Code:
    $ zmlocalconfig |grep ldap_url
    ldap_url = ldap://mailz.xxx.it:389
    i have setupped a replica server on mbox.xxx.it
    i would that
    store server uses replica and then master.

    i used this syntax, exctly:
    Code:
    $ zmcontrol stop
    $ zmlocalconfig -e ldap_url="ldap://mbox.xxx.it:389 ldap://mailz.xxx.it:389"


    changed only domain name to xxx for privacy

    is this syntax correct?

    "After updating the ldap_url, rerun /opt/zimbra/libexe/zmmtainit."

    i did it after zmlocalconfig

    Code:
    $ /opt/zimbra/libexec/zmmtainit
    (corect typo on wiki page, it's libexec)

    then i started
    Code:
    $ zmcontrol start


    tia
    Last edited by maumar; 07-11-2008 at 07:57 AM.

  3. #3
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    8

    Unhappy

    i have found that something is wrong in replica installation:
    issuing
    $ zmlocalconfig -s ldap_root_password ldap_replication_password

    on master and replica server, they are different;
    in this wiki
    LDAP - Zimbra :: Wiki

    is reported clearly:
    Code:
    #  Set the LDAProot password to the correct value (run zmlocalconfig -s ldap_root_password on the master to determine this value)
    # Set the LDAP replication password to the correct value (run zmlocalconfig -s ldap_replication_password on the master to determine this value)
    in the document i used, instead, nothing is said about ldap_replication_password:
    "http://www.zimbra.com/docs/ne/latest/multi_server_install/LDAP Replication.6.1.html" with a space between LDAP and Replication (why do u put spaces in urls??):

    Code:
     3.
    	
    Type 1 to display the Common Configuration submenus. Type 2 to change the Ldap Master host name to the name of the Master LDAP host.
    4.
    	
    Type 3, to change the port to the same port as configured for the Master LDAP server.
    5.
    	
    Type 4 and change the password to the Master LDAP server password.
    you should fix documentation

    setting ldap_root_pasword and ldap_replication_password on replica server to be the same of master, however, does not fix 49 error

    zimbra.log on replica server reports:
    Jul 12 06:03:38 mboxra slapd[13009]: do_syncrep1: rid 100 ldap_sasl_bind_s failed (49)

    there is some nasty error in replica installation; i opened a ticket and a zimbra guy is behind it, at the moment.

Similar Threads

  1. Problem Install Zimbra ver 5.0.4_GA_2101.F7
    By maman in forum Installation
    Replies: 5
    Last Post: 04-14-2008, 12:50 PM
  2. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  3. Fedora 8 install
    By ahuman in forum Installation
    Replies: 31
    Last Post: 02-15-2008, 07:37 AM
  4. Zimbra install errorr on FC 4 - Please help
    By gva_1030 in forum Installation
    Replies: 16
    Last Post: 02-14-2008, 03:52 PM
  5. Fedora - latest versions?
    By sternfan in forum Installation
    Replies: 8
    Last Post: 01-09-2008, 04:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •