Results 1 to 7 of 7

Thread: An invalid request was made

Hybrid View

  1. #1
    Join Date
    May 2008
    Location
    California!
    Posts
    226
    Rep Power
    7

    Default An invalid request was made

    Ok I'm not really sure what is causing this error, but I've attached a screenshot:

    Only one user is having this issue, and it seems to happen when she attaches a file or attempts to save a draft. She's running WinXP and IE7.

    I'm not really sure what this error means or even where to look for more information. Any ideas out there?

  2. #2
    Join Date
    Jul 2008
    Posts
    1
    Rep Power
    7

    Default invalid request Can't save draft.

    Our Chief Information Officeer is having a zimbra web client issue. She is intermittently having difficulties saving a message as a draft, especially after she has edited the message.
    When this behavior occurs she is also unable to add an attachment.

    In both cases the folowing message is returned:

    Invalid Request Made
    msg:invalid request: missing required attribute :a
    code: service.INVALID_REQUEST
    method: Save Draft_REQUEST
    soap sender:

    This problem is visible in the mailbox log on the mailstore.
    From /opt/zimbra/log/mailbox.log
    2008-11-04 09:12:29,226 INFO [btpool0-4350] [name=account & IP Address;u
    a=ZimbraWebClient - IE7 (Win)/5.0.10_GA_2638.RHEL5_64;] soap - SaveDraftRequest
    2008-11-04 09:12:29,227 INFO [btpool0-4350] [name=USER & IP;ua=ZimbraWebClient - IE7 (Win)/5.0.10_GA_2638.RHEL5_64;] SoapEngine - handler exception
    Last edited by hsu-sysadmin; 11-04-2008 at 11:16 AM.

  3. #3
    Join Date
    May 2010
    Posts
    25
    Rep Power
    0

    Default Same problem on 5.0.23

    I know this is 2+ years old, but I have a number of users getting the exact
    same error. Users are going to the web client, editing a message or editing
    a draft, or trying to save a draft, and hit the exact same error. Is this an
    anomoly? Has anyone else seen this?

  4. #4
    Join Date
    Nov 2010
    Posts
    25
    Rep Power
    4

    Default

    It's been reported from one of my users that he got the same problem when uploading attachments.

    In the log it says:

    Code:
    com.zimbra.common.service.ServiceException: invalid request: missing required attribute: a
    ExceptionId:btpool0-42://xx.xxx:8080/service/soap/SaveDraftRequest:1294730240418:1a7fa22d5f591681
    Code:service.INVALID_REQUEST
            at com.zimbra.common.service.ServiceException.INVALID_REQUEST(ServiceException.java:255)
            at com.zimbra.common.soap.Element.checkNull(Element.java:240)
            at com.zimbra.common.soap.Element.getAttribute(Element.java:208)
            at com.zimbra.cs.service.mail.ParseMimeMessage$MessageAddresses.add(ParseMimeMessage.java:822)
            at com.zimbra.cs.service.mail.ParseMimeMessage.parseMimeMsgSoap(ParseMimeMessage.java:367)
            at com.zimbra.cs.service.mail.ParseMimeMessage.parseMimeMsgSoap(ParseMimeMessage.java:195)
            at com.zimbra.cs.service.mail.SaveDraft.handle(SaveDraft.java:94)
            at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:420)
            at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:274)
            at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:158)
            at com.zimbra.soap.SoapServlet.doWork(SoapServlet.java:291)
            at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:212)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
            at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:181)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
            at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1166)
            at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(SetHeaderFilter.java:79)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)
            at org.mortbay.servlet.UserAgentFilter.doFilter(UserAgentFilter.java:81)
            at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter.java:132)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)
            at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:388)
            at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:218)
            at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)
            at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:765)
            at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:418)
            at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230)
            at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
            at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
            at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle(RewriteHandler.java:230)
            at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
            at org.mortbay.jetty.handler.DebugHandler.handle(DebugHandler.java:77)
            at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
            at org.mortbay.jetty.Server.handle(Server.java:326)
            at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:543)
            at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:939)
            at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:755)
            at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212)
            at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:405)
            at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:413)
            at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:451)

  5. #5
    Join Date
    May 2010
    Posts
    25
    Rep Power
    0

    Default

    Interesting. We have moved to 6.0.9 recently, and I have not seen the problem yet, but I will admit on 5.X the problem was fairly rare, and then we would seemingly get it for a day or so, and then it would go away.

  6. #6
    Join Date
    May 2008
    Location
    California!
    Posts
    226
    Rep Power
    7

    Default

    Quote Originally Posted by number9 View Post
    Interesting. We have moved to 6.0.9 recently, and I have not seen the problem yet, but I will admit on 5.X the problem was fairly rare, and then we would seemingly get it for a day or so, and then it would go away.
    Our circumstances are similar. The temporary workaround was to copy the body of the message, and paste to an entirely new message. Also, does this happen for you when the user has a file attached? I found that my users with this problem were attaching files from a deep subfolder (c:\subfolder\subfolder\subfolder\subfolder\file.t xt). They also named their folders and files with complete sentences. :-)

  7. #7
    Join Date
    Apr 2010
    Posts
    14
    Rep Power
    5

    Lightbulb Found probable cause

    We experienced this error, and after significant time of investigation, found out that the cause was an error / typo in one of the address, specifically, there are one address that have 2 "@" sign (or 2 addresses compressed into one), something like: abcde@fghij@klmnop.com

    Not sure if this is general cause of this kind of error, but IMHO Zimbra should give better error message than this for the particular case we experienced.

Similar Threads

  1. Problem with Mail Server - Need help!
    By joeleo in forum Installation
    Replies: 2
    Last Post: 03-04-2008, 11:03 AM
  2. Inconsistent Zimbra install behaviour
    By mkolbjor in forum Installation
    Replies: 2
    Last Post: 02-07-2008, 02:52 AM
  3. Postfix problem
    By jimbo in forum Administrators
    Replies: 46
    Last Post: 07-23-2007, 05:24 AM
  4. Replies: 26
    Last Post: 02-12-2007, 06:23 PM
  5. An invalid request was made
    By deepblue in forum Administrators
    Replies: 5
    Last Post: 01-25-2007, 02:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •