Results 1 to 3 of 3

Thread: Disaster & Recovery of Open Source Edition

  1. #1
    Join Date
    Mar 2008
    São Paulo - Brasil
    Rep Power

    Default Disaster & Recovery of Open Source Edition

    Hi folks!

    Last night I completely destroy my Zimbra OSE binaries, but I have saved a backup of the following dirs:


    My distro is a Ubuntu 6.06 with Zimbra 5.0.5. I have done a fresh install of both, Ubuntu and Zimbra WITH the same password, and I have tried to delete this dirs of the fresh install and copying the ones from my saved backup into this fresh working install, dir per dir.

    What I have done on my new install:

    su - zimbra
    zmcontrol stop
    # kill other zimbra owned process (perl zmlogger in my case)
    cd /opt/zimbra
    mv db db-bkp
    cd logger/
    mv db db-bkp
    cd ..
    mv openldap-data openldap-data-bkp
    mv store store-bkp
    cp -a /opt/zimbra-BKP/db .
    cp -a /opt/zimbra-BKP/logger/db logger/
    cp -a /opt/zimbra-BKP/openldap-data .
    cp -a /opt/zimbra-BKP/store .
    /opt/zimbra/libexec/zmfixperms #to garantee
    zmcontrol start #(log vide attached file zimbra-startup.txt)

    Some services works, but others no, see attached file zimbra-status.txt.

    Is this the right procedure for disaster recovery of opensource edition?

    Have I miss some directory, maybe /opt/zimbra/conf ?

    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2006
    Rep Power


    Yes you would need /opt/zimbra/conf. Why not just use one of the many OSE backup procedures ?

  3. #3
    Join Date
    Mar 2008
    São Paulo - Brasil
    Rep Power


    This procedures does not work for me... maybe because my copy of Zimbra is totaly broken and in my /opt/zimbra/conf, the localconfig.xml is missing... so, after switching new empty databases with my ones, I can't connect in mysql with user zimbra, because mysql and ldap password are wrong (with new localconfig.xml).
    I started another MySQL (from ubuntu package), put /opt/zimbra/db/data/mysql into it (renaming to mysql-zimbra), changed root and zimbra passord (with phpmyadmin) with ones founded in new localconfig.xml and put back mysql database into zimbra dir.
    My old /opt/zimbra/conf dir is useless.
    After syncinc all passwords from new localconfig.xml, "zmcontrol start" works again!
    Thanks for you help!

Similar Threads

  1. [Installation] Zimbra Desktop - Ubuntu 8.04 Hardy
    By kaltera in forum Installation Help
    Replies: 1
    Last Post: 06-18-2008, 04:43 AM
  2. Replies: 3
    Last Post: 04-12-2008, 03:35 PM
  3. [SOLVED] Is zimbra really open source product ?
    By hernad in forum Developers
    Replies: 3
    Last Post: 08-18-2007, 10:30 PM
  4. Error message in Server status
    By Max Ma in forum Installation
    Replies: 20
    Last Post: 04-19-2007, 08:55 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts