Results 1 to 5 of 5

Thread: Dspam

Threaded View

  1. #1
    Join Date
    Feb 2008
    Rep Power

    Default Dspam

    When enabling DSPAM I have read that I also should enable the commented DPSAM related linex in crontab
    # Dspam cleanup
    0 1 * * * find /opt/zimbra/dspam/var/dspam/data/z/i/zimbra/zimbra.sig/ -type f -name \*sig -mtime +7 -exec rm {} \; > /dev/null 2>&1
    8 4 * * * /opt/zimbra/dspam/bin/dspam_logrotate -a 60 /opt/zimbra/dspam/var/dspam/system.log
    7 8 * * * /opt/zimbra/dspam/bin/dspam_logrotate -a 60 /opt/zimbra/dspam/var/dspam/data/z/i/zimbra/zimbra.log
    As always I test new crontabs I set, and when running the 2 logrotate lines I get an error

    [zimbra@smtp09 ~]$ /opt/zimbra/dspam/bin/dspam_logrotate -a 60 /opt/zimbra/dspam/var/dspam/system.log
    Usage: /opt/zimbra/dspam/bin/dspam_logrotate -a age [-v] -l logfiles
    Usage: /opt/zimbra/dspam/bin/dspam_logrotate -a age [-v] -d /var/dspam
    [zimbra@smtp09 ~]$ /opt/zimbra/dspam/bin/dspam_logrotate -a 60 /opt/zimbra/dspam/var/dspam/data/z/i/zimbra/zimbra.log
    Usage: /opt/zimbra/dspam/bin/dspam_logrotate -a age [-v] -l logfiles
    Usage: /opt/zimbra/dspam/bin/dspam_logrotate -a age [-v] -d /var/dspam
    Is it just to add the -l to the line? Also, the 3rd line that involves "/opt/zimbra/dspam/var/dspam/data/z/i/zimbra/zimbra.log" I get a permission denied, when I run
    chown -R zimbra:zimbra /opt/zimbra
    and thrn try to run the command it works, and I am able as zimbra user to open that logfile, but once I run the
    it stops working again, when I check that script I see that zmfixperms resets the owner on the /opt/zimbra/dspam/var/dspam folder (recursivly) to root:root. So my question is, which one should it be, zimbra or root user? Should I not be able to do the crontabed lines manually?

    Also I see now that I cant get DSPAM started at all actually. "No $dspam, not using it", that comes up when I start amavis with /opt/zimbra/amavisd/sbin/amavisd -c /opt/zimbra/conf/amavisd.conf debug

    EDIT2: I also see that after the upgrade I did yesterday from 5.0.2 to 5.0.8 my /opt/zimbra/amavisd/.spamassassin/ is very empty, can I just restore that dir from backup and run zmfixperms? I guess that dir holds the learnt spam (that I have spent quite some time updating with downloaded spam packages..).
    Last edited by osiris; 07-17-2008 at 03:06 AM.
    Release 5.0.8_GA_2462.RHEL5_20080709170039 RHEL5 FOSS edition

Similar Threads

  1. Enabling DSPAM
    By osiris in forum Administrators
    Replies: 80
    Last Post: 09-20-2012, 04:10 PM
  2. dspam errors after 5.0 upgrade
    By Krishopper in forum Administrators
    Replies: 2
    Last Post: 12-20-2007, 04:57 PM
  3. dspam broke after 4.5.7 upgrade?
    By Krishopper in forum Administrators
    Replies: 9
    Last Post: 09-24-2007, 08:07 AM
  4. Configuring and using DSPAM
    By JoshuaPrismon in forum Administrators
    Replies: 55
    Last Post: 03-02-2007, 08:08 AM
  5. Rewrote zmtrainsa for DSPAM
    By unilogic in forum Developers
    Replies: 18
    Last Post: 01-12-2006, 05:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts