Results 1 to 2 of 2

Thread: GoDaddy Cert Problems

Hybrid View

  1. #1
    Join Date
    Jul 2008
    Posts
    21
    Rep Power
    7

    Default GoDaddy Cert Problems

    Hi Everyone,

    So I am really at a loss right now. I am totally unable to get the GoDaddy certs that I purchased to install correctly on my Zimbra server. I'm to the point now that I'm thinking about just totally rebuilding my server from scratch and reimporting in the message stores.

    Every time I try to import the Godaddy crt files I get the same error:
    Your certificate was not installed due to the error : system failure: XXXXX ERROR: Unmatching certificate (/opt/zimbra/ssl/zimbra/commercial/commercial.crt) and private key (/opt/zimbra/ssl/zimbra/commercial/commercial.key) pair.

    I have spent hours on this forum reading the posts and reading the Wiki pages about how to install a GoDaddy signed certificate and none of it has worked for me. It is clear to me that something is simply screwed up in my Zimbra server configuration.

    Does anyone know of the steps I could take to start over from scratch with my keystores and certificate files? Just like Zimbra would be after a fresh install? I really think that is my only choice other then totally starting from scratch with the server.

    Any help would be greatly appreciated.

    Nate

  2. #2
    Join Date
    Jul 2008
    Posts
    21
    Rep Power
    7

    Default

    Ok, so I've gotten a little further but to exactly the same point as I got before. First of all the name on the cert is different then the host name. The cert is "webmail.example.com." and the server name is: "servername.example.com." I read somewhere that this might cause a problem but I put the second name in the "alternate" field. So that should be OK.

    Second, I followed the steps here:
    Commercial Certificate in 5.x - Zimbra :: Wiki

    I verified the cert, everything was looking fine. I then installed the cert, I got a message that the install was a success. So I then went to navigate to https://webmail.myserver.com and the page never loads. I then went to https://hostname.myserver.com and the page never loads. It times out both times after a minute.

    I cleared the certificate store in the browser and tried it again with the same results. I then tried it in IE 6 with the same results.

    This is exactly the point I got to earlier. I can get the certs installed but when I try to connect to the server the connection just times out.

    Hopefully someone has been through this and can give some feedback. Thanks!

    Nate

Similar Threads

  1. Upgrade Self Signed Cert to Commercial Cert (godaddy)
    By lareck in forum Administrators
    Replies: 1
    Last Post: 01-04-2010, 02:51 AM
  2. Zimbra Hates GoDaddy
    By void in forum Administrators
    Replies: 18
    Last Post: 07-09-2009, 11:27 AM
  3. Install GoDaddy Cert
    By sunfire in forum Administrators
    Replies: 1
    Last Post: 07-16-2008, 06:10 AM
  4. Replies: 2
    Last Post: 03-25-2007, 10:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •