Results 1 to 3 of 3

Thread: LDAP Crashing

  1. #1
    Join Date
    Nov 2005
    Location
    London, ON
    Posts
    255
    Rep Power
    10

    Default LDAP Crashing

    Over the last couple of months I've been having an issue with one of my LDAP servers. A few times a week the LDAP service crashes, the mail system carries on because my backup server picks everything. But I am getting paged at 1AM a few time a week and it is very frustrating. When I upgraded the servers last time I was hoping it would resolve the issue, it did for a couple of weeks, but after a while it started to get worse and it is almost a daily occurrence now. I have attached the log file from the ldap server, any help is appreciated. Thanks!
    Attached Files Attached Files

  2. #2
    Join Date
    Dec 2007
    Posts
    3
    Rep Power
    8

    Default

    I have the same issue which started after I upgrade to 5.x.
    After debugging I found that the zimbra-openldap version 2.3.41 was calling the ldap libraries from the Linux distribution /usr/lib/libldap2.2*, which I suspect is what cause the ldap to crash.
    Unfortunately, in my case I couldn’t uninstall the libraries, since we use them for our own authentication. So, I ended with writing a script that will restart zimbra-ldap when it dies .
    I hope this help.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by m.nistor@delcan.com View Post
    I have the same issue which started after I upgrade to 5.x.
    After debugging I found that the zimbra-openldap version 2.3.41 was calling the ldap libraries from the Linux distribution /usr/lib/libldap2.2*, which I suspect is what cause the ldap to crash.
    Unfortunately, in my case I couldn’t uninstall the libraries, since we use them for our own authentication. So, I ended with writing a script that will restart zimbra-ldap when it dies .
    I hope this help.
    It shouldn't be using those libraries, did you file a bug report about the problem? Which operating system is this?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. LDAP Cannot bind on migration to new server
    By neekster in forum Migration
    Replies: 23
    Last Post: 03-09-2009, 03:08 AM
  2. upgrading from 5.0.4 to 5.0.5 opensource
    By smoke in forum Installation
    Replies: 4
    Last Post: 10-19-2008, 11:38 AM
  3. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM
  4. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 03:39 PM
  5. Replies: 4
    Last Post: 11-15-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •