Results 1 to 8 of 8

Thread: [SOLVED] CentOS 5 zcs-NETWORK-5.0.8_GA_2462.RHEL5_64

Hybrid View

  1. #1
    Join Date
    Jul 2008
    Posts
    4
    Rep Power
    8

    Default [SOLVED] CentOS 5 zcs-NETWORK-5.0.8_GA_2462.RHEL5_64

    For some reason snmp and mta will not startup on the system. When I run zmcontrol start my ouput is this:

    Starting mailbox...Done.
    Starting imapproxy...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...Done.
    Starting mta...FAILED
    postsuper: fatal: scan_dir_push: open directory defer: Permission denied
    postfix failed to start


    Starting stats...Done.


    any ideas?

  2. #2
    Join Date
    Feb 2007
    Location
    Sioux Falls, SD
    Posts
    67
    Rep Power
    10

    Default

    Hi, just double checking, you are running the zmcontrol as the zimbra user? You can also try running /opt/zimbra/libexec/zmfixperms as root and try starting the services again as the zimbra user.
    CoSentry - www.cosentry.com - Co-Location & Business Resiliency Solutions

  3. #3
    Join Date
    Jul 2008
    Posts
    4
    Rep Power
    8

    Default

    I have already ran that script, still nothing

  4. #4
    Join Date
    Feb 2007
    Location
    Sioux Falls, SD
    Posts
    67
    Rep Power
    10

    Default

    This post recommends uninstalling iptables and disabling SE linux.

    What is the output when you just try to start the MTA service by itself?

    $> zmmtactl start

    Also, can you give me an idea on where this install is coming from (i.e. is it a fresh install or an upgrade and if so, from what version)?

    Thanks!
    CoSentry - www.cosentry.com - Co-Location & Business Resiliency Solutions

  5. #5
    Join Date
    Jul 2008
    Posts
    4
    Rep Power
    8

    Default

    I have already disabled se linux and stopped IPtables. This is a fresh install on CentOS 5. Sorry it took so long to get back to you, here is the output from the zmmctrl command:

    Mon Jul 28 12:32:56 2008 Service archiving is not enabled. Skipping archiving
    Mon Jul 28 12:32:56 2008 Rewrote: /opt/zimbra/conf/salocal.cf
    Mon Jul 28 12:32:56 2008 Rewrote: /opt/zimbra/conf/clamd.conf
    Mon Jul 28 12:32:56 2008 Rewrote: /opt/zimbra/cyrus-sasl-2.1.22.3z/etc/saslauthd.conf
    Mon Jul 28 12:32:56 2008 Rewrote: /opt/zimbra/conf/postfix_header_checks
    Mon Jul 28 12:32:56 2008 Rewrote: /opt/zimbra/conf/freshclam.conf
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e sender_canonical_maps='ldap:/opt/zimbra/conf/ldap-scm.cf'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e virtual_alias_domains='ldap:/opt/zimbra/conf/ldap-vad.cf'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e lmtp_connection_cache_time_limit='4s'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e recipient_delimiter=''
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_cert_file='/opt/zimbra/conf/smtpd.crt'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_auth_only='yes'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e myhostname='forum.part.net'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e virtual_mailbox_domains='ldap:/opt/zimbra/conf/ldap-vmd.cf'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e mydestination='localhost'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e mailbox_size_limit='0'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e setgid_group='postdrop'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e smtpd_client_restrictions='reject_unauth_pipelinin g'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e queue_run_delay='300s'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e minimal_backoff_time='300s'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e virtual_alias_maps='ldap:/opt/zimbra/conf/ldap-vam.cf'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e transport_maps='ldap:/opt/zimbra/conf/ldap-transport.cf'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e sendmail_path='/opt/zimbra/postfix/sbin/sendmail'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e message_size_limit='10240000'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e broken_sasl_auth_clients='yes'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e lmtp_connection_cache_destinations=''
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e alias_maps='hash:/etc/aliases'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e manpage_directory='/opt/zimbra/postfix/man'
    Mon Jul 28 12:32:56 2008 Executing /opt/zimbra/postfix/sbin/postconf -e smtpd_helo_required='yes'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e in_flow_delay='1s'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e daemon_directory='/opt/zimbra/postfix/libexec'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e maximal_backoff_time='4000s'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e virtual_transport='error'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e mynetworks='127.0.0.0/8 172.29.29.0/24 '
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e smtpd_recipient_restrictions='reject_non_fqdn_reci pient, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_unlisted_recipient, reject_invalid_hostname, reject_non_fqdn_sender, permit'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e lmtp_host_lookup='dns'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_loglevel='1'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e relayhost=''
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e disable_dns_lookups='no'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e mail_owner='postfix'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e virtual_mailbox_maps='ldap:/opt/zimbra/conf/ldap-vmm.cf'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e version='2.4.7.5z'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e mailq_path='/opt/zimbra/postfix/sbin/mailq'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e header_checks='pcre:/opt/zimbra/conf/postfix_header_checks'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e smtpd_use_tls='yes'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e queue_directory='/opt/zimbra/data/postfix/spool'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e newaliases_path='/opt/zimbra/postfix/sbin/newaliases'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e smtpd_reject_unlisted_recipient='no'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e smtpd_data_restrictions='reject_unauth_pipelining'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e local_header_rewrite_clients='permit_mynetworks,pe rmit_sasl_authenticated'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_key_file='/opt/zimbra/conf/smtpd.key'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e command_directory='/opt/zimbra/postfix/sbin'
    Mon Jul 28 12:32:57 2008 Executing /opt/zimbra/postfix/sbin/postconf -e smtpd_sasl_auth_enable='yes'
    postsuper: fatal: scan_dir_push: open directory defer: Permission denied
    postfix/postfix-script: fatal: Postfix integrity check failed!
    postfix failed to start

  6. #6
    Join Date
    Feb 2007
    Location
    Sioux Falls, SD
    Posts
    67
    Rep Power
    10

    Default

    From the looks of it, it is getting denied permissions from the deferred queue.

    Check your permissions and ownership of: /opt/zimbra/data/postfix/spool

    Mine look as follows:

    drwx------ 2 postfix postfix 1 Jul 28 13:47 active
    drwx------ 2 postfix postfix 1 Jul 28 13:46 bounce
    drwx------ 2 postfix postfix 1 Mar 21 03:09 corrupt
    drwxr-xr-x 18 postfix postfix 4096 Mar 21 03:07 defer
    drwxr-xr-x 18 postfix postfix 4096 Mar 21 03:07 deferred
    drwx------ 2 postfix postfix 1 Mar 21 03:09 flush
    drwx------ 2 postfix postfix 1 Mar 21 03:09 hold
    drwx------ 2 postfix postfix 1 Jul 28 13:47 incoming
    drwx-wx--- 2 postfix postdrop 1 Jun 18 00:09 maildrop
    drwxr-xr-x 2 postfix postfix 4096 Mar 21 13:30 pid
    drwx------ 2 postfix postfix 4096 Jul 27 01:23 private
    drwx--x--- 2 postfix postdrop 4096 Jul 27 01:23 public
    drwx------ 2 postfix postfix 1 Mar 21 03:09 saved
    drwx------ 2 postfix postfix 1 Jul 28 12:54 trace

    Thanks,
    Dusty
    CoSentry - www.cosentry.com - Co-Location & Business Resiliency Solutions

  7. #7
    Join Date
    Jul 2008
    Posts
    4
    Rep Power
    8

    Default

    Thanks, it looks like it was the permissions on the spool directory itself! Thanks for your help!

  8. #8
    Join Date
    Feb 2007
    Location
    Sioux Falls, SD
    Posts
    67
    Rep Power
    10

    Default

    Good deal! Glad it worked.

    Dusty
    CoSentry - www.cosentry.com - Co-Location & Business Resiliency Solutions

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 04:52 AM
  2. ZCS 10 IMAP/POP3 mail sending problem outside network
    By uscell in forum Administrators
    Replies: 8
    Last Post: 10-10-2008, 11:31 PM
  3. Replies: 41
    Last Post: 10-29-2007, 02:36 PM
  4. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 03:46 PM
  5. Zimbra startup hangs after install CentOS 4.2
    By eger in forum Installation
    Replies: 4
    Last Post: 02-10-2006, 10:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •