Results 1 to 4 of 4

Thread: Migrating Accounts from LDAP with {crypt} Passwords

Hybrid View

  1. #1
    Join Date
    Mar 2006
    Location
    Hamburg, Germany
    Posts
    44
    Rep Power
    9

    Default Migrating Accounts from LDAP with {crypt} Passwords

    I'm migrating users from SLOX 4.1 to the OSE. SLOX by default stores passwords in LDAP as {crypt}, and I found the following thread describing how to migrate {crypt} passwords.

    http://www.zimbra.com/forums/showthread.php?t=1163

    However, it's not working for me. Authentication succeeds with any other encryption scheme, but when I save a {crypt} password, authentication fails.

    Is openldap perhaps compiled without the --enable-crypt option? I suspect this, since slappasswd also refuses to output passwords as {crypt}.

    Version 3.0.1_GA_160.RHEL4
    Scott Hanson
    Media Ventures GmbH
    Cologne, Germany

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Yep we were missing the --enable-crypt in a recent build. It'll be in there for the next major release.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Mar 2006
    Location
    Hamburg, Germany
    Posts
    44
    Rep Power
    9

    Default

    Would it work to recompile the ldap rpm with that option and drop it into my installation? Would that also work for the Network Edition?
    Scott Hanson
    Media Ventures GmbH
    Cologne, Germany

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by shanson
    Would it work to recompile the ldap rpm with that option and drop it into my installation? Would that also work for the Network Edition?
    It should assuming you use all our other compile options.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Similar Threads

  1. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  2. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  3. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 02:39 PM
  4. Replies: 4
    Last Post: 11-15-2006, 11:16 AM
  5. Migrating Accounts from LDAP with Encrypted Passwords
    By andreychek in forum Administrators
    Replies: 3
    Last Post: 12-16-2005, 02:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •