Results 1 to 5 of 5

Thread: Relay problems

Hybrid View

  1. #1
    Join Date
    Oct 2007
    Location
    Paris
    Posts
    15
    Rep Power
    8

    Default Relay problems

    Hello, I'm having some problems configuring a relay on zimbra.

    -> I've created a domain called first.com and another second.com
    -> filled the users with the zmprov commands
    -> while were waiting for a complete migration of first.com, i've configure the domain to relay to the old postfix with the folloing commands :

    zmprov md first.com zimbraMailCatchAllAddress @first.com
    zmprov md first.com zimbraMailCatchAllForwardingAddress @first.com
    zmprov md first.com zimbraMailTransport relayld-postfix.com

    When a user user@second.com send a mail to a user@first.com, the mail stay in the zimbra server and it's not relayed by the zimbra.

    When i look in zimbra.log, it's say relay=127.0.0.1 or the name of the server

    zimbra.log :

    Jul 31 13:09:17 zimbra postfix/smtpd[10738]: connect from localhost.localdomain[127.0.0.1]

    Jul 31 13:09:17 zimbra postfix/smtpd[10738]: 69C2A511DF3E: client=localhost.localdomain[127.0.0.1]

    Jul 31 13:09:17 zimbra postfix/cleanup[10741]: 69C2A511DF3E: message-id=<1504039315.811217502557349.JavaMail.root@zimbr a.ovh.net>

    Jul 31 13:09:17 zimbra postfix/qmgr[31184]: 69C2A511DF3E: from=<userb@second.com>, size=644, nrcpt=1 (queue active)

    Jul 31 13:09:17 zimbra postfix/smtpd[10738]: disconnect from localhost.localdomain[127.0.0.1]

    Jul 31 13:09:17 zimbra amavis[29683]: (29683-02) ESMTP::10024 /opt/zimbra/data/amavisd/tmp/amavis-20080731T130202-29683: <userb@second.com> -> <usera@first.com> SIZE=644 Received: from zimbra.ovh.net ([127.0.0.1]) by localhost (zimbra.ovh.net [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <usera@first.com>; Thu, 31 Jul 2008 13:09:17 +0200 (CEST)

    Jul 31 13:09:17 zimbra amavis[29683]: (29683-02) Checking: C7pxlFr1ZVOH [127.0.0.1] <userb@second.com> -> <usera@first.com>

    Jul 31 13:09:17 zimbra postfix/smtpd[10743]: connect from localhost.localdomain[127.0.0.1]

    Jul 31 13:09:17 zimbra postfix/smtpd[10743]: B4128511DF41: client=localhost.localdomain[127.0.0.1]

    Jul 31 13:09:17 zimbra postfix/cleanup[10741]: B4128511DF41: message-id=<1504039315.811217502557349.JavaMail.root@zimbr a.ovh.net>

    Jul 31 13:09:17 zimbra postfix/qmgr[31184]: B4128511DF41: from=<userb@second.com>, size=1306, nrcpt=1 (queue active)

    Jul 31 13:09:17 zimbra postfix/smtpd[10743]: disconnect from localhost.localdomain[127.0.0.1]

    Jul 31 13:09:17 zimbra amavis[29683]: (29683-02) FWD via SMTP: <userb@second.com> -> <usera@first.com>,BODY=7BIT 250 2.6.0 Ok, id=29683-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as B4128511DF41

    Jul 31 13:09:17 zimbra amavis[29683]: (29683-02) Passed CLEAN, LOCAL [127.0.0.1] [127.0.0.1] <userb@second.com> -> <usera@first.com>, Message-ID: <1504039315.811217502557349.JavaMail.root@zimbra.o vh.net>, mail_id: C7pxlFr1ZVOH, Hits: 3.061, size: 644, queued_as: B4128511DF41, 299 ms

    Jul 31 13:09:17 zimbra postfix/smtp[10742]: 69C2A511DF3E: to=<usera@first.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.32, delays=0.01/0/0/0.3, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as B4128511DF41)

    Jul 31 13:09:17 zimbra postfix/qmgr[31184]: 69C2A511DF3E: removed

    Jul 31 13:09:17 zimbra postfix/lmtp[10744]: B4128511DF41: to=<usera@first.com>, relay=zimbra.ovh.net[91.X.X.X]:7025, delay=0.06, delays=0.01/0/0/0.05, dsn=2.1.5, status=sent (250 2.1.5 OK)

    Jul 31 13:09:17 zimbra postfix/qmgr[31184]: B4128511DF41: removed

    My configuration :
    Zimbra 5.0.8 NE

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Did you do
    Code:
    su - zimbra
    zmmtactl stop ; zmmtactl restart
    ?

  3. #3
    Join Date
    Oct 2007
    Location
    Paris
    Posts
    15
    Rep Power
    8

    Default

    yes, and nothing change

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by sktwolf View Post
    yes, and nothing change
    I presume you've followed the Secondary Server instructions in the Split Domain article? Does the postfix server get resolved by DNS to an internal IP? Can you provide some dns output to show that it resolves correctly?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Oct 2007
    Location
    Paris
    Posts
    15
    Rep Power
    8

    Default

    the server resolve the right ip adress, but in the zimbra, the relay is not taken.

    I can not provide rights logs due to privacy...

    thank for helping

Similar Threads

  1. Could use some advise: Re: Relay setup
    By DMRDave in forum Administrators
    Replies: 3
    Last Post: 07-18-2008, 10:05 PM
  2. New installation: mail relay & SOAP problems
    By cheros in forum Installation
    Replies: 3
    Last Post: 04-24-2008, 01:20 AM
  3. Adding external relay to existing installation
    By sean.lutner in forum Administrators
    Replies: 1
    Last Post: 02-05-2008, 01:58 PM
  4. Problems with outgoing SMTP Relay
    By cyber_jack in forum Administrators
    Replies: 3
    Last Post: 01-10-2008, 03:38 PM
  5. iSync Connector / Apple Address Book Problems
    By jrosen in forum CalDAV / CardDAV / iSync
    Replies: 11
    Last Post: 04-16-2007, 04:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •