Results 1 to 3 of 3

Thread: External authentication to Zimbra LDAP

  1. #1
    Join Date
    Mar 2006
    Posts
    5
    Rep Power
    9

    Default External authentication to Zimbra LDAP

    I have looked over the forums, and can't seem to find a good answer to this. Most questions are asking about the other way around.

    I have Zimbra installed, configured, and running. I want to use the Zimbra LDAP server to authenticate other applications. All I need is a username/password for the other apps.

    I have tried to decode* the Zimbra LDAP myself, but havn't been successful. How is the username/email address and password referred to in the Zimbra LDAP?

    Currently, I am running a plain OpenLDAP server, and users are stored as follows:

    cn=j.moore,ou=people,dc=chc,dc=local

    I tried the similar against Zimbra LDAP, changing a few parts, but have had no luck.

    Any help would be appreciated.

    Thanks,
    Jon

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    You can look in the zimbra.schema file or use an LDAP browser to discover the tree. The passwords for LDAP can be retrieved from zmlocalconfig
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Mar 2006
    Posts
    22
    Rep Power
    9

    Default

    Quote Originally Posted by thejonmoore
    cn=j.moore,ou=people,dc=chc,dc=local
    Try:

    uid=username,ou=people,dc=exmaple,dc=com

    Where "username" is the first half of the users email.

    Works for me.

Similar Threads

  1. Replies: 26
    Last Post: 04-19-2011, 10:24 AM
  2. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM
  3. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM
  4. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM
  5. Seeming variety of problems on suse-9.1
    By Crexis in forum Installation
    Replies: 52
    Last Post: 03-04-2006, 12:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •