Results 1 to 3 of 3

Thread: [SOLVED] errors found in Database Integrity check report

  1. #1
    Join Date
    Feb 2007
    Location
    Ireland
    Posts
    125
    Rep Power
    8

    Default [SOLVED] errors found in Database Integrity check report

    Good morning,
    I see its busy today, lots of new threads.
    Hopefully this one will be easy

    Got this error this morning. We did upgrade to 5.0.8 on 24/7/08 without any problems or errors

    Ahh!! now I remember the server shutdown after power outage and ups ran out ( happened over weekend and I am looking into graceful shutdowns in future)

    How can I recover from this?

    Database errors found.
    /opt/zimbra/mysql/bin/mysqlcheck --defaults-file=/opt/zimbra/conf/my.cnf -S /opt/zimbra/db/mysql.sock -A -C -s -u root --password=password_removed
    zimbra.jiveUserProp
    warning : 1 client is using or hasn't closed the table properly

    The mysql_error. log reads
    [root@mail log]$ more mysql_error.log
    080810 23:13:22 mysqld started
    InnoDB: The log sequence number in ibdata files does not match
    InnoDB: the log sequence number in the ib_logfiles!
    080810 23:13:23 InnoDB: Database was not shut down normally!
    InnoDB: Starting crash recovery.
    InnoDB: Reading tablespace information from the .ibd files...
    InnoDB: Restoring possible half-written data pages from the doublewrite
    InnoDB: buffer...
    080810 23:13:56 InnoDB: Started; log sequence number 1 2682440946
    080810 23:13:56 [Note] /opt/zimbra/mysql/libexec/mysqld: ready for connections.
    Version: '5.0.51a-log' socket: '/opt/zimbra/db/mysql.sock' port: 7306 Source distribution

  2. #2
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Rerun the report with the -r options to attempt to auto-repair the tables.
    /opt/zimbra/libexec/zmdbintegrityreport -r -v
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Feb 2007
    Location
    Ireland
    Posts
    125
    Rep Power
    8

    Default that seems to have fixed it

    /opt/zimbra/libexec/zmdbintegrityreport -r -v
    Generating report
    No errors found

    I guess its ok now but I would have liked to see it fix or ask to fix something.

    Thanks, Brian

Similar Threads

  1. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 12:44 PM
  2. Replies: 20
    Last Post: 03-18-2008, 06:37 AM
  3. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  4. Replies: 2
    Last Post: 10-04-2007, 04:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •