G'day

I noticed a few days ago this error in the logs (see below) after email was being accepted but not delivered.

I am using Ubuntu 6.0.6.2 x64 and Zimbra 5.0.9. Problem was also occurring on Zimbra 5.0.8.

Code:
Aug 30 20:43:59 mail slapd[3855]: conn=395 fd=12 ACCEPT from IP=127.0.0.1:56012 (IP=127.0.0.1:389)
Aug 30 20:43:59 mail slapd[3855]: conn=395 op=0 STARTTLS
Aug 30 20:43:59 mail slapd[3855]: conn=395 op=0 RESULT oid= err=0 text=
Aug 30 20:43:59 mail postfix/trivial-rewrite[21103]: error: dict_ldap_connect: Unable to set STARTTLS: -11: Connect error
Aug 30 20:43:59 mail slapd[3855]: conn=396 fd=20 ACCEPT from IP=127.0.0.1:56013 (IP=127.0.0.1:389)
Aug 30 20:43:59 mail slapd[3855]: conn=396 op=0 STARTTLS
Aug 30 20:43:59 mail slapd[3855]: conn=396 op=0 RESULT oid= err=0 text=
Aug 30 20:43:59 mail slapd[3855]: conn=397 fd=21 ACCEPT from IP=127.0.0.1:56014 (IP=127.0.0.1:389)
Aug 30 20:43:59 mail slapd[3855]: conn=397 op=0 STARTTLS
Aug 30 20:43:59 mail slapd[3855]: conn=397 op=0 RESULT oid= err=0 text=
Aug 30 20:43:59 mail last message repeated 2 times
Aug 30 20:43:59 mail postfix/trivial-rewrite[21103]: fatal: ldap:/opt/zimbra/conf/ldap-vad.cf(0,lock|fold_fix): table lookup problem
Aug 30 20:43:59 mail slapd[3855]: conn=398 fd=22 ACCEPT from IP=127.0.0.1:56015 (IP=127.0.0.1:389)
Aug 30 20:43:59 mail slapd[3855]: conn=398 op=0 STARTTLS
Aug 30 20:43:59 mail slapd[3855]: conn=398 op=0 RESULT oid= err=0 text=
Aug 30 20:43:59 mail postfix/trivial-rewrite[21104]: error: dict_ldap_connect: Unable to set STARTTLS: -11: Connect error
Aug 30 20:43:59 mail slapd[3855]: conn=399 fd=23 ACCEPT from IP=127.0.0.1:56016 (IP=127.0.0.1:389)
Aug 30 20:43:59 mail slapd[3855]: conn=399 op=0 STARTTLS
Aug 30 20:43:59 mail slapd[3855]: conn=399 op=0 RESULT oid= err=0 text=
Aug 30 20:43:59 mail slapd[3855]: conn=400 fd=24 ACCEPT from IP=127.0.0.1:56017 (IP=127.0.0.1:389)
Aug 30 20:43:59 mail slapd[3855]: conn=400 op=0 STARTTLS
Aug 30 20:43:59 mail slapd[3855]: conn=400 op=0 RESULT oid= err=0 text=
Aug 30 20:43:59 mail last message repeated 2 times
Aug 30 20:43:59 mail postfix/trivial-rewrite[21104]: fatal: ldap:/opt/zimbra/conf/ldap-vad.cf(0,lock|fold_fix): table lookup problem
Aug 30 20:44:00 mail postfix/smtpd[18753]: warning: problem talking to service rewrite: Success
Aug 30 20:44:00 mail postfix/master[3749]: warning: process /opt/zimbra/postfix/libexec/trivial-rewrite pid 21103 exit status 1
Aug 30 20:44:00 mail postfix/master[3749]: warning: /opt/zimbra/postfix/libexec/trivial-rewrite: bad command startup -- throttling
Aug 30 20:44:00 mail slapd[3855]: conn=397 fd=21 closed (TLS negotiation failure)
Aug 30 20:44:00 mail slapd[3855]: conn=396 fd=20 closed (TLS negotiation failure)
Aug 30 20:44:00 mail slapd[3855]: conn=395 fd=12 closed (TLS negotiation failure)
Aug 30 20:44:00 mail postfix/master[3749]: warning: process /opt/zimbra/postfix/libexec/trivial-rewrite pid 21104 exit status 1
Aug 30 20:44:00 mail postfix/smtpd[18294]: warning: problem talking to service rewrite: Success
Aug 30 20:44:00 mail slapd[3855]: conn=400 fd=24 closed (TLS negotiation failure)
Aug 30 20:44:00 mail slapd[3855]: conn=399 fd=23 closed (TLS negotiation failure)
Aug 30 20:44:00 mail slapd[3855]: conn=398 fd=22 closed (TLS negotiation failure)
I tried to fix this by following these articles and searching the forums:
http://www.zimbra.com/forums/install...y-failure.html
Error (MTA): Unable to set STARTTLS - Zimbra :: Wiki
Problem with Certificate can cause MTA Failure - Zimbra :: Wiki
SSL Certificate Problems - Zimbra :: Wiki

The only change I'd made to this install in the last few months was to deploy a commercial SSL certificate, after the self-signed on expired and I got caught by the Zimbra upgrade bug

What is really frustrating is that the problem is intermittent. It will run fine for days or occur a few hours after a reboot.

If you've seen and solved this problem before, then I'd really appreciate your advice. (Otherwise this one's going to Zimbra support).

Cheers!